When trying to use Start.Sh doesn't work or executing not the way it suppose to

Hi there I have been using Mine OS for a while now.

There is some things Ive learn on the forum but it seems to never work for me

I looked up CRON way and I never will bother with that since its seems very limited as what ive seen.

I tried using the start.sh way from spigot using

cd /usr/games/minecraft
./mineos_console.py -s NAME start

And so many others.

All i get to do is run the /restart command and all it does as shutdown the server. There is no restart.
(I do want the server always up)

I made sure the .sh files were execute-ables using [chmod +x start.sh]

Has something changed in MineOS that causes this not to work? Do i need add something more? Let me know.

Which account is the owner? Have you changed the permissions to 777 (-rwxrwxrwx)?

I am the account owner. (vanilla) I don’t think I have. I thought +x does that or no?

I will give that a try.

I have tried this. However it seems to work but the server kills it afterwards.

Double check the ownership and permissions, they should not be set to root.

According to FileZilla they are owned by (Vanilla) with -rwxrwxrwx perms

Do you have an account called Vanilla? I believe they should be mc.

Yes I have an account called Vanilla and got rid of mc

Can you post the mineos.log output?

I added to a pastebin
there was 17,000kb worth of stuff I only took the only parts that were needed.

I have. It seems to send the start command to console but it doesn’t start. Maybe I have to delay the start some how?

So far running this script:

date >> /var/games/minecraft/servers/goldrush/starts.log
setsid ./waitandrun.sh & >> /var/games/minecraft/servers/goldrush/starts.log
echo end of start.sh >> /var/games/minecraft/servers/goldrush/starts.log


echo startau start >> /var/games/minecraft/servers/goldrush/starts.log
sleep 30
cd /usr/games/minecraft
./mineos_console.js -s goldrush start >> /var/games/minecraft/servers/goldrush/starts.log 2>&1
echo startau end >> /var/games/minecraft/servers/goldrush/starts.log
date >> /var/games/minecraft/servers/goldrush/starts.log

This was from Issue 104 from github

However when using this it give me this

[TestScript] Error executing “start” because server condition not met: !up
startau end

Another issue I seem to have is py is now -> js probably because its newer + this script was back from 2014 era

Also when tried replacing start to restart… you get this

[TestScript] Error executing “restart” because server condition not met: true
startau end

Why are you invoking “mineos.Py” ? That is the server script from the previous python based version of MineOS. MineOS was moved over to node.js quite a few years ago.

So if you have a python version of MineOS it is hopelessly outdated, and I reccomend a total reinstall and upgrade to MineOS-node.

If you have the node version, trying to invoke the python script will not work, since that file is not there.

That what I was saying. old scripts where using Python. I had to change it to node.JS otherwise I kept getting mineos.py doesn’t exist etc.

Plus I did change the .py to .js already I just copied that from issue 104

Only thing I can think of is making a CRON tell the server to try to start every 5 mins?

ASSUMING it will cancel if the server is already up?

It almost sounds like it just might be easier to reinstall from the bottom up using the node.js. Then try making the modifications you want.

Be easier if you read correctly.

node.js already came installed from the wiki. NOT using an old version

All I said was since python was used back then none of the scripts will work in newer mineos.

The script your’e using dumps all output into this log. What do that log say?