Whats a good java browser?

All my browsers automatically updated and so did my java, and I have checked to make sure it was update to date, it is.

That being said, I can not run https://192.168.1.XXX:12321/filemanager on any of these browswers as the file manager requires java.

The file manage is very important for me, without it I can no longer make timely editions to my plugin config files, and without that I can’t really work on my server.

That being said I currently have installed Torch, IE-sharp, Avast, Google Chrome, Google Chromium, FireFox, and Opera. None of these are capable of running the java applet.

Any suggestions on a browser I can use, i assure you if i could code as well as you I would just make my own, as I only need it for ease of transfering server files but sadly i am not that good at coding.

hi Jonathan_Martin,

i think you are getting a false error message.

please take note of the following message from Sir hexparrot:
hexparrot Elder Mar 121
In the interest of minimalism, Webmin doesn’t start up by default anymore; those who wish to continue to use it may still do so by running this command:

update-rc.d webmin enable
service webmin start

And also opening up the relevant ports in iptables as you have. Sorry it’s not documented anywhere.

so please ensure you also manually open port 12321 in the ip tables.

thanks and good luck!


What actual error do you get? Did you simply update a browser or did you change the whole MineOS installation?

What OS are you using, that all your browsers automatically updated? Is it possible to downgrade your recent Java update?

Please try to provide some more information on the exact problem you’re having so we can help address it.

for the issue… the actual error…

“This module requires java to function, but your browser does not support java
Return to Webmin index.”

after clicking on file manager.

This issue use to not exist and now does, I have tried very browser I can think of , none of them work, I have wasted hours upon hours, over a week of my life because no one here seemed to listen, and nothing worked.

All i need is a browser that works with the file manager.

Just to try to get right to something practical and immediately useful–have you tried just abandoning this issue with Java-browser based incompatibilities?

Everything you’d want to do with Webmin you could do outside of webmin, and a week of your life could be spent instead learning the tools that conventionally help admins manage their server:

normal SFTP client, e.g., filezilla.
normal text editor, e.g., vi / nano on terminal.

What you’re running into isn’t a MineOS issue, nor is it a webmin issue: it’s a Java installed on your desktop and integrated with your browser issue.

Since it’s so narrowly scoped, I think it would be way better to learn the other tools that let you do these things–just as easily–but without the huge incompatibility issue you’re experiencing.

1 Like