WebUI Stop/Restart fails

Hello everyone,

I am having trouble with my MineOS Turnkey server. I am running vanilla 1.16.1 Minecraft on my server (just upgraded an older server to 1.16.1) and for some reason whenever the webUI tries to stop or restart the server I get this error:
pastebin.com/XCMEWphQ

java.lang.NullPointerException

And then the server just sits there “UP” and never shuts down or restarts unless i use /kill (the stop button in the webUI does not work, it says it fails whenever I try).

This issue seems to coincide with updating the profile to 1.16.1, but I also had a power outage around the same time so that could be the cause, but I think it happened after updating but before the power outage so I don’t think it’s that.

I tried updating the WebUI to see if that would help (using https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui) but I get errors whenever I try that. I have always gotten errors when trying to update the WebUI and have had to do a clean install in the past to get around that.

What is your current commit? Have you updated the OS recently? And what is your OS version? (Run the command cat /etc/*-release
Can you delete the 1.16.1 jar file and redownload it?
Any issues with creating a new server, updating another one?

I just tried on a different vanilla server, running 1.15.2, and I can use the Stop button successfully. The current commit version is 9cf8fe1. I update everything whenever the updater tells me to, but I’m not sure exactly when the last time that was.
Here is the result when I run that command you suggested:
https://pastebin.com/ZFj9BsYk

Edit: I will try deleting and redownloading the 1.16.1 jar file
Edit2: That did not seem to work. Stop still fails.

What values do you have for the java heaps? Which version of java is installed? And are you using Wheezy, Jessie or Stretch version?