WebUI Server not starting

Hi, I recently made my own server that I was going to use as my modded server. I was able to get the WebUI up and running but whenever I click the start button, nothing happens. I made sure everything from my knowledge is filled out. I am using a version of MineOS that was loaded on top of a 21.10 version of ubuntu. I looked at some of the older threads and tried updating WebUI in the terminal as well as redownloading the java file to see if those worked, to no avail

Some tips:
Have you checked your logs?
/var/games/minecraft/[servername]/logs/latest.log (I think this is the location, it may be one directory down though)

Your logs often give some hints of what is happening or not.

Also you could try to start your server manually through SSH. this would give you the verbose output from the jar file. If there are any mismatches or errors in Java handling it should push out an error message there.

It looks like you use a predefined modded server, any details? A lot of them have to be compiled and prepared in place, so it may be that someting is missing.

when testing the server I only used a vanilla server. I tried 1.18, 1.17, and 1.12.2 with the same result

when checking my logs, I get a FAILED TO BIND TO PORT error, stating cannot assign requested address. It also says perhaps a server is already running on that port. Iā€™m going to change the ip to something else to see if that fixes it, but is there a way for me to check to see if its already in use?

Fail to bind to port means there is a server already running on that ip on that port.
if you have more than one server set up make sure to change the port in server properties to the next available port e.g. 25566

In your minecraft servers it is reccomended to leave the IP-setting at This meanst that the server listens to all available network interfaces on the machine the server runs on.

If you run more than one minecraft server, you need to make sure each server has a separate uniqe port. So if your first server uses the standard 25565, that port is taken. I usually just count upward, so the next server has port 25566, and so on.

Java being java, it occationally hangs, or forgets to clean up after it self. a reboot may clear up any services that are blocking your server.

I ended up trying a bunch of things to get it to work, and resetting the ip to, and it seemed to work. Thank You!

1 Like