WebUI not loading properly and is very slow


Hope someone can help with this. I am running MineOS turnkey and it has been working great for a number of years.

Yesterday the WebUI starting becoming slow and would not load.

I went through resetting the webui via Putty as I have done before, however this has not fixed it.

The Webui does load but very slowly. It takes a while to load but the Webui is very messed up and does not show properly.

The servers are also not running, if I try to log on via minecraft it shows they are not running.

I think something somewhere is not working properly. Can someone help me diagnose the issue and put things back to normal. My son and I would greatly appreciate it!

The webui doesn’t always let me login, it will sometimes just look back to the login screen.

It is very very slow to load and when it does load, it is messed up and a lot of items are missing.

Other times it will load and there is no text, just a gradient background.

Please someone help me figure this out.

I’m following the guide to reset the webui. On this command

git reset --hard origin/master

I get this notice/error

HEAD is now at 1e040bb update ISO url

Is this a clue to what could be the issue?, what does the ‘update ISO url’ mean?

Someone please help:

My webui is showing template text such as:

{{ servers_up() }}

{{ players_online() }}

{{ host_heartbeat.uptime | seconds_to_time }}

{{ host_heartbeat.freemem | bytes_to_mb }}

{{ host_diskspace.freedisk | bytes_to_mb }}

I have done

npm install --unsafe-perm

As instructed in the guide to reset to ui. None of my servers are running and I’m out of ideas. Have been on this for hours and tried various things and have probably messed it up even further.

Please someone help me put this right or help diagnose what the issue could be.

Thanks again in advance.

A machine slowing down could indicate running out of space or other hardware issue.

The git command was fine, it is informing you what commit you’re on. I checked and that is the most recent.

The issue with the placeholder could be that the node server isn’t running. After/ during log in the server may have crashed. You could check by logging in then seeing if the service has stopped using the CLI.

Thanks so much for coming back to me. I’m a total newbie in terms in linux commands. I just copy and paste what I can find online. I think yes you could be right about the node.js

I have tried to follow some commands online and believe I have v14.x installed.

Can you tell me what commands I need to put into PuTTy to help diagnose the issue.

Regarding space, when I login via PuTTy it says I have used 91% of the disk and I have around 5GB free which I would have thought is plenty, but could possibly be an issue as I have not pruned the backups in a while.

I have since deleted some of the restore points on my servers using this command via PuTTy.

rdiff-backup --force --remove-older-than 2W /var/games/minecraft/backup/SERVER

Where is says ‘SERVER’ I have put my server name. This deleted quite a few backups I had on various servers.

I now have 23% disk free so should be enough resources for mineos to run.

However I still cannot get the WebUI to load. I get the login in screen, but when I try and login, it hangs and just returns back to the login screen again.

I have used the command.

systemctl status mineos

And can confirm mineos is running.

My node version is v14.21.3
My NPM version is npm 6.14.18

Hope someone can help.

I can sometimes get into the Webui but it is messed up with template text all over the place.

I have followed the instructions to reset the webui but the issue still persists.

Where else can I look?

Check that the permissions on the git cloned folder and it’s file and folder contents are root:root.

Thanks for this.

I did,

stat -c “%U %G” /usr/games/minecraft

and it output,

root root

So I presume its not a permission issue?

root@mineos-tkldev /home/mc# ls -l /usr/games/minecraft
total 448
-rw-r–r-- 1 root root 1696 Sep 6 10:20 Dockerfile
-rw-r–r-- 1 root root 1571 Sep 6 10:20 Dockerfile.dev
-rw-r–r-- 1 root root 35147 Nov 9 2018 LICENSE.md
-rw-r–r-- 1 root root 578 Jul 6 2021 Makefile
-rw-r–r-- 1 root root 4434 Nov 9 2018 README.md
-rw-r–r-- 1 root root 4243 Apr 26 2020 auth.js
-rw-r–r-- 1 root root 2146 Jul 6 2021 docker-compose.yml
drwxr-xr-x 5 root root 4096 Feb 20 17:49 docs
-rwxr-xr-x 1 root root 3514 Nov 20 22:40 entrypoint.sh
-rw-r–r-- 1 root root 2889 Apr 26 2020 generate-sslcert.sh
drwxr-xr-x 7 root root 4096 Sep 6 10:20 html
drwxr-xr-x 2 root root 4096 Aug 12 2020 init
-rw-r–r-- 1 root root 1844 Sep 6 10:20 install_rootless.sh
-rw-r–r-- 1 root root 662 Sep 6 10:20 java.js
-rw-r–r-- 1 root root 284 Apr 26 2020 mineos.conf
-rw-r–r-- 1 root root 55764 Sep 6 10:20 mineos.js
-rw-r–r-- 1 root root 4256 Feb 28 10:01 mineos_console.js
drwxr-xr-x 400 root root 20480 Feb 28 10:34 node_modules
-rw-r–r-- 1 root root 163208 Feb 28 10:34 package-lock.json
-rw-r–r-- 1 root root 2259 Feb 28 10:34 package.json
drwxr-xr-x 2 root root 4096 Sep 6 10:20 profiles.d
-rw-r–r-- 1 root root 570 Sep 6 10:20 profiles.js
-rw-r–r-- 1 root root 1291 Sep 6 10:20 reset_webui.sh
drwxr-xr-x 2 root root 4096 Jul 6 2021 selinux
-rw-r–r-- 1 root root 53463 Sep 6 10:20 server.js
-rwxr-xr-x 1 root root 772 Nov 9 2018 service.js
-rw-r–r-- 1 root root 1524 Feb 28 00:28 temctl start mineos?OM?On
drwxr-xr-x 2 root root 4096 Sep 6 10:20 test
-rw-r–r-- 1 root root 1073 Sep 6 10:20 update_webui.sh
-rwxr-xr-x 1 root root 10808 Sep 6 10:20 webui.js

Ok. Before you log in, open the browser developer tools → console.

Log in and see if any errors show up in the console.

I have tried this and on the login screen there is a bunch of errors relating to jquery. I would post a screenshot but the forum doesn’t let me upload images for some reason.

Hi Richard,

I’ve had troubles lately as well.

I would do a reinstall. I took notes as I reinstalled today.
This worked on Ubuntu 20

sudo -i

apt -y install curl

# check java sersion
java -version

# install v17 if required
wget https://github.com/adoptium/temurin17-binaries/releases/download/jdk-17.0.6%2B10/OpenJDK17U-jdk_x64_linux_hotspot_17.0.6_10.tar.gz -O openjdk-17-jre.tgz
tar xf openjdk-17-jre.tgz 
mv jdk-17.0.* /opt/openjdk-17.0-jre
rm /usr/bin/java
ln -s /opt/openjdk-17.0-jre/bin/java /usr/bin/java

java -version

# Remove nodejs
apt-get remove nodejs

# Then a little tidy
# manually remove node from here
nano /etc/apt/sources.list.d

# remove anything else
rm -rf /usr/local/bin/npm 
rm -rf /usr/local/share/man/man1/node* 
rm -rf /usr/local/lib/dtrace/node.d
rm -rf ~/.npm
rm -rf ~/.node-gyp
rm -rf /opt/local/bin/node
rm -rf /opt/local/include/node
rm -rf /opt/local/lib/node_modules
rm -rf /usr/local/lib/node*
rm -rf /usr/local/include/node*
rm -rf /usr/local/bin/node*

# install nodejs
curl -sL https://deb.nodesource.com/setup_14.x | bash -
apt -y install nodejs

# install mineos
cd /usr/games/
# remove the old mineos
rm -rf /usr/games/minecraft/
git clone https://github.com/hexparrot/mineos-node.git minecraft
cd minecraft
git config core.filemode false
chmod +x generate-sslcert.sh mineos_console.js webui.js
# remove the old conf
rm /etc/mineos.conf
cp mineos.conf /etc/mineos.conf

# do the npm thing
npm install --unsafe-perm

# gen sert

# remove the old service
rm /etc/systemd/system/mineos.service
cp init/systemd_conf /etc/systemd/system/mineos.service
systemctl enable mineos

# does it work
systemctl start mineos
systemctl status mineos

Let me know if any of that helps


Thanks so much for this. I have sadly powered down that machine, replaced the SSD and installed another platform on it. Moved my servers on there and am as happy as Larry. The replacement platform is a closed source paid-for platform, not very expensive however and extremely easy and reliable to manage. This was meant to be the way MineOS was meant to be like, for us non techs to be able to spin up a Minecraft server with ease and without issues.

I now have the latest Debian 11 system which is headless like MineOS and with super easy control panel to manage my Minecraft servers. I can also easily install other version of Java and run different servers with different versions of Java. I also installed Cockpit to manage the Debian server with a web GUI.

When MineOS works, it works and its great, however when things break, you have to dig in to CLI and learn new things, which isn’t bad, but not the original reason I chose MineOS.

So then you have to come on here begging for help. Don’t get me wrong when people do help here, it’s great and a wonderful community with people such as yourself. However often things go unanswered and you are left to deal with it yourself such as in my case.

If I have the time, I will swap out the SSD and try your fixes. However I did try so many things and nothing worked, I believe there was an issue with the source itself which may have been patched by now.

Thank you again for your time in your reply.