WebUI loading login page once rebooted but will not login or refresh

hi all,

not too sure how to fix this problem so wandering if anyone can help.

iv been running MineOS on Ubuntu 15.04 running within VM Ware for about two weeks now with no issues at all until now.
i was setting up cron jobs for backups etc. and all of a sudden the webUI froze and the server connection timed out. i have tried restarting the mineos service, rebooting the VM rebooting the physical host and checked that all IP and port forwards are correct. i have a feeling the cron jobs may be causing some sort of glitch but not too sure if I’m correct?


I had a report that invalid cronjobs could potentially crash the webui. I’ll have to look into it. In the meantime, go through each of your servers you’ve been working on and remove the cron.config content; after a restart, it’ll probably be up and running again.

Also, what are the cron you’re trying to create? Perhaps we can review them (and or use it to test) and see whats going on.

i reinstalled the mineos webui and it was all good until i tried to delete the cron job through the webui and it broke again, so i deleted the cron.config file, rebooted the server and its all working again, it was a error i made in a cron for a server backup every 12 hours that i tried to fix and it broke more than it fixed,

thanks for the help much aprciated

I identified a bug that crashed the webui when an invalid cronjob existed. I have since updated the webui so that it can tolerate invalid cron expressions and auto-disable them.

I’m still working on making it friendlier (by having information about cron on the page) but in the meantime, updating your webui should help avoid the crashes.

As root:

cd /usr/games/minecraft
git fetch
git pull
npm install

Since you’re on Ubuntu 15 (which uses systems), restart MineOS with:

systemctl stop mineos
systemctl start mineos
1 Like

Thanks for the help!! So glad to see how active the development is for this project!!