WebUI external connection

I’m busy with my minecraft server and want to access the webUI externally. My ports are forwarded and https://www.portchecktool.com/ says my ports are open, but when i fill in my ddns and :8443 at the end, it says ‘connection refused’ or ‘empty response’. I’ve accepted all inputs with iptables for port 8443 but still no use. How can i fix this?

Edit: Port 22 and 25565 do work externally, only the webUI (8443) doesn’t work

Sometimes ISPs block common ports for servers and 8443 is not too uncommon, though I would have figured 22 might have been blocked if that was the case but you never know.
Are you ensuring your using https:// and not http://?
Sounds like you’ve got your linux firewall set up to allow all ports required (could try disabling completely) and router set up to forward to the correct IP with the correct ports. DDNS forwarding to the correct IP? Does https://:8443 work?

I know it’s not blocked because the port check tool can see port 8443 and it’s open, but when i fill in my ddns.com:8443 it doesn’t connect. In my home network i can access the webUI just fine. I think it doesn’t work because of http when i fill in my ddns.com:8443

I fixed it! it was indeed http instead of https (so http:dns.com:8443 in stead of https:dns.com:8443

now i have a new problem. When i want to close the port for everyone accept my friends using iptables, it doesn’t work and stays open for everyone. iptables -A INPUT -p tcp --dport 8443 -j DROP