Webserver Problems with Setup

I attempted setup of the most recent 64-bit version of MineOS today. The setup seemed to go perfectly fine, but when I tried to connect to the Web-UI, I got an immediate ERR_EMPTY_RESPONSE (using Chrome). I’ve tried the setup a few times now, and I’ve pulled the most recent version of the Web-UI from https://github.com/hexparrot/mineos-node (and I tried a few older versions), but after a few hours of trying whatever I could imagine, I’ve concluded I have no idea what the problem is. Please help me.

What I know:
SSH works.
When I run webui.js, a node process starts listening on 8443 (according to netstat).
When I run webui.js, it almost immediately moves to the background. I feel like that might not be right.

I’d recommend just killing all nodejs processesand then attempting to start the service using the supervisorctl approach.

supervisorctl start mineos

That said, restarting the host also could accomplish the same thing.

However, for whatever reason it might not be working… can you provide the contents of /var/log/mineos.log?

I tried killing the node webui.js process, but a new instance of it immediately starts every time I try, and when I try to start supervisorctl it says mineos: ERROR (already started). I’ve tried restarting a few times with no noticeable change. The log looks like this: http://pastebin.com/79ugRYje (I was trying out older versions).

supervisorctl mineos stop
cd /usr/games/minecraft
chmod +x ./webui

This will stop the process from opening on it’s own after it dies. Then, when you start it up again, maybe you can see with more information why it’s not staying alive.

supervisorctl stop mineos worked to keep it from restarting, and it stays in the foreground when I run it manually now, but other than that, it seems to behave exactly the same way. Here’s the output

root@mineos games/minecraft# ./webui.js 
base_directory found in mineos.conf, using: /var/games/minecraft
info: Starting up server, using commit: d057581 rate limiting responds only when sustained

MineOS webui listening on HTTPS://

No other output comes out. I tried to change the sockethost ipaddress to both and the machine’s local ipaddress, and though the output of webui.js changed accordingly, the behavior remains unchanged. Also, the logfile just has more of the same stuff.

For whatever reason, if I turn off HTTPS, it works completely fine.

Either of these would make it not work–you never want a server listening on because that means only the MineOS host can connect to the webui…and what you want to do is connect from other machines, like your desktop.

Based on what I’m seeing, I’m inclined to think you forgot to put the :8443 in the web browser to tell it to connect to port 8443? Because when you turn off HTTPS, it resorts to 80, which is implied.

In other words, I think it worked the entire time, just you were connecting to https://[ip]:80 instead of of https://[ip]:8443 like expected.

Ah, I forgot to say, when I tried listening on localhost, I was testing by trying to wget https://localhost:8443. Also, I’m sure I never tried port 80 until now, and it actually doesn’t work now that I try it, either with https on or off.