Web-UI not letting me create servers

I just tried to install MineOS on my fileserver. I had installed Turnkey Fileserver on it a few months ago and I went through the steps listed here: http://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS-node_(apt-get)

And the end result was something similar to this: [SOLVED] Web-UI will not allow creation of servers and Web-UI looks broken with the template naming conventions. But doing the “npm install userid” didn’t seem to fix the problem.

Here are some hopefully helpful lines from the log file: http://pastebin.com/d18nDcms

Thanks in advance for any help!

uncaughtException: groupname not found",“timestamp”:“2016-06-18T15:05:17.431Z”}

Does your logged-in user have a primary group associated with it?

Check in the command line: groups and ensure it is not empty.

Yeah, the primary group is ‘users’, I’ve got a secondary group attached to it too but even if I make a new user that only has ‘users’ as a group, it still doesn’t work as expected.

Something isn’t working as expected with groups. The traceback is calling out the following line 237:


This line directly relates to figuring out the GID of your username:

What happens when you type this in from the command line:

var userid = require('userid')

Change username to your actual username. Does this throw an error?

Yeah, I get…

$ node                                                                                                                      
> var userid = require('userid')
> userid.gid("joel")
Error: groupname not found                                                                                                  
    at Error (native)                                                                                                       
    at Object.exports.gid (/usr/games/minecraft/node_modules/userid/lib/userid.js:39:18)                                    
    at repl:1:8                                                                                                             
    at REPLServer.defaultEval (repl.js:262:27)                                                                              
    at bound (domain.js:287:14)                                                                                             
    at REPLServer.runBound [as eval] (domain.js:300:12)                                                                     
    at REPLServer.<anonymous> (repl.js:431:12)                                                                              
    at emitOne (events.js:82:20)                                                                                            
    at REPLServer.emit (events.js:169:7)                                                                                    
    at REPLServer.Interface._onLine (readline.js:211:10)

Are you sure joel has a primary group? Or that the assigned group id for the user refers to a currently existing group?

What is the output from id joel at the console?

I’m reasonably sure its apart of a real group. (I’m not a Linux expert though so I could be missing something) The webmin panel has ‘users’ as Joel’s primary group there.

And here’s the console output.

$ id joel uid=1000(joel) gid=100(users) groups=100(users),1000(joelplex)