Web-UI and Server not working

So I just installed MineOS on a relatively old computer (Pentium Dual CPU T3200 2GHz with 3 GB of ram and a ATI Mobility Radeon HD 2400 with 256 MB of VRAM), and it was working correctly, the Web-UI opened no problem, the server ran just fine on lan and everything was ok. But I wanted to play with friends over the internet so I port forwarded, that’s when the problems started, the server was running fine, I even got people to join over the internet, but the Web-UI just didn’t connect, I made sure it was https and that it would be on port 8443 but it still didn’t connect, at this point I wasn’t too worried and just continued, so I decided to install the graphics drivers along with the Open CL and Vulkan APIs, that’s when everything went wrong, neither the Web-UI or the server worked, the Web-UI stayed the same and the server showed up on lan servers but didn’t connect, ssh was working and I did a ping test successfully so it is not a connectivity issue.
I tried searching through your forums but I found nothing, does anyone know what the problem is and how to fix it?

EDIT: Forgot to mention: also updated system files, through apt-get update apt-get dist-upgrade apt-get upgrade, and the Web-UI, with instructions from https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui

EDIT: After following the instructions on the website again I got 3 log files: http://www.mediafire.com/file/l3fxrehd633dfj2/2020-02-26T09_07_02_655Z-debug.log/file

EDIT: Added my MineOS.log file:

EDIT: Now the server does not even appear on the minecraft server list, I can still ssh into the server

All right, so I was able to get the Web-UI working again by running node /usr/games/minecraft/webui.js but I don’t know what happened and if when the server is restarted it will open automatically

It’s fixed! At least partially… Running node /usr/games/minecraft/webui.js fixed the Web-UI problem, the catch is that my server disappeared, working on that now.

For some reason the user mc lost a bunch of permissions and I don’t know how to get them all back, at least from what I have seen because I had to make the webui.js file readable and executable so mc could run it, maybe when I updated? I updated as root so maybe it just updated a bunch of files as root and didn’t maintain the permissions for mc.

EDIT: Updating Web-UI is not working. Outputs this error:
gyp ERR! build error gyp ERR! stack Error: makefailed with exit code: 2 gyp ERR! stack at ChildProcess.onExit (/root/.nvm/versions/node/v12.14.1/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23) gyp ERR! stack at ChildProcess.emit (events.js:223:5) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:272:12) gyp ERR! System Linux 4.19.0-8-amd64 gyp ERR! command "/root/.nvm/versions/node/v12.14.1/bin/node" "/root/.nvm/versions/node/v12.14.1/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd /usr/games/minecraft/node_modules/posix gyp ERR! node -v v12.14.1 gyp ERR! node-gyp -v v5.0.5 gyp ERR! not ok npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! posix@4.1.2 install:node-gyp rebuild npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the posix@4.1.2 install script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Try downgrading to Node v10.

Different lines of NodeJS development have different APIs and I rely on a lot of publicly maintained packages, such as posix

posix doesn’t appear to have successfully built for node 12, but I have confirmed it’s still good to go on node v10. Without this package properly built, the webui just cannot operate.

Long story short, downgrade to nodev10 and rerun ./reset_webui.sh

Oh thank god, I was about to give up, but it works! Thanks, guess it updated Node when running the updates.