User randomly disconnects from server


#1

Hey.

So when im messing around with my minecraft server hosted with mineOS on Turnkey linux I, and other players, get randomly disconnected with a Java io exception stating “An existing connection was forcibly closed by the remote host”

Then I can rejoin right away.

Is there any way to fix this?


#2

This is a network related error, with several possible sources:

  1. a bug in the minecraft server jars network handling routines.
  2. incorrect settings in your network router
  3. firewall settings on one of the hosts between client and server (including both)
  4. antivirus settings on one of the hosts between client and server (including both)

Without more information we cannot help you discover where and why this happends.

Information we need:
Logs! (mineos.log and latest.log, for the WebUI and for the minecraft server)
Do you connect and play over LAN or do your connect over the internet?
Have you configured port forwarding?
Do you run more than one minecraft server?
Which minecraft server are you runing? (vanilla, bukkit, spigot, FTBstyle, pocketmine)
And what version?
Have you tried updating both the WebUI and the minecraft server?


#3
[01:25:09] [User Authenticator #2/INFO]: UUID of player zbk is 59810176-d74c-3cba-ba74-737a263e3d45
[01:25:09] [Server thread/INFO]: eJoin> ezbke
[01:25:09] [Server thread/INFO]: zbk[/127.0.0.1:45825] logged in with entity id 2244 at ([world]-33.0, 62.0, 10.0)
[01:26:59] [Server thread/INFO]: zbk lost connection: Disconnected
[01:26:59] [Server thread/INFO]: zbk left the game

Thats all that happended. No sartup errors.

Over the internet through my domain. (happenes on LAN too)

Yes, incomming port 25565 is routed to 25565

Yes, 1 Spigot and 1 BungeeCord

1.11.2 Latest build of Spigot

Installed yesterday and installed all updates yesterday through commands on the wiki.


#4

Neither clients have AntiVirus software and their firewalls are disabled (temporary, dont worry)


#5

Did this happen before the update?


#6

Updates were done as soon as MineOS was installed from the iso.

EDIT: so didnt have servers at the time


#7

According to these two forum post regarding spigot and that disconnect issue:


It is either a problem with how your router is set up to handle IP routing, or a plugin/mod error.

Have you tried starting up a vanilla server to confirm that this happends with that also?


#8

Running the test. Playing from outside network on vanilla 1.11.2


#9

Little update.

Vanilla worked fine. Spigot w/ local IP works now.

Currently testing domain.

This all happend after I restarted my router.