Uploading a server

I’ve tried to import a server with from archive,I’ve uploaded the zip file at /var/games/minecraft/import and press that buton,create from archive and send me to server status but doesn’t create my server and I can’t start it.I’ve tried also to create a new server,upload the .zip and unzip in the server folder,but when I try to start my server doesn’t do nothing,when I refresh the page it reload very slow and when I login I lose all my progress (Build tools instaled,spigot instalation and all my servers.

It sends you to server status, but doesn’t create the server?

If you see a start button, it should pretty much be created. What happens when you hit start?

When you upload the zip and unzip it, have you verified all the unzipped files are extracted exactly where you expect them? When you hit start, do you get any error messages? (Usually failed starts still at least say they failed).

Your server can be logged into, but you said it didn’t start…?

Please let us know any details we can use to help figure out what’s going on here. A few key points would be:

  • what version of MineOS are you using (commit)
  • whats the contents of /var/log/mineos.log?
  • what’s the contents of the zipfile you’re using (and is it share-able and test-able)?

The zip file has some worlds,the plugins folder with plugins Like essentials,multiverse,etc,also in the zip file are spigot-1.8.8.jar,craftbukkit-1.8.8.jar,BuildTools.jar,server.properties and files Like spigot.yml,bukkit.yml.baned-players,etc.

I’ve uploaded the zip file via bitivise ssh client,user root.

When I imported the server I didn’t saw the server in my server list,and when I press the start buton I saw a window with profile,jar file,memory (xMS,xMX),I completed all of this,and click start,but nothing happened.

How I check my mineOS version ?

MineOS log(my server name is rocrafting - rocrafting.zip): https://www.dropbox.com/s/uoxwfug10s3zzit/mineos.log?dl=0

Based on your mineos.log, it could be some sort of issue with the server software itself; perhaps (as is the case with some plugins like JSONAPI) the server is not responding as MineOS expects it to each of the heartbeats.

Sharing the actual zip file if possible would be the best; secondly, can you confirm from the command line that no existing java processes are running?

When start does nothing, it could be that each attempt to start the server (presumably port 25565) fails because there’s already an unintentionally still-open-server running there. This would be consistent with the notion that you say you cannot start a server, but yet you were able to still log in. I’d say this is the most likely issue you’re experiencing at this moment.

Restarting the whole host would be another way to safely ensure the rogue server is down.

Hello all,

I just updated, did a fresh install of Turnkey MineOS from the website and I am experiencing the same bugs as Dino14. The webui does not create new or import servers. When I attempt to create/import it allows access to the server status page. As soon as I logoff and log back in, I have no access to the server and there are no server folders created in the /var/games/minecraft/servers directory. The tags below in the server status page that show archives or restorepoints read NaNundefined or in the case of the Delete section: NaNundefined/servers/

As this is a fresh install, I have not been able to get a server running from this version. Also due in part for the profiles not working for me but I have manually imported before so I didn’t need to use the profile function before.
Here’s a link to my log as well as two screenshots of what the server status page looked like.


This is more or less normal, when there are no files created for archive or backup yet. As for delete: If our server is not created, there is no files to be able to delete. NaNundefined basically means: I did not find any of the types of files to do anything with.

Importing server:
Where did you place the server archive of the server you are trying to import? How did you transfer it there? Did you use the “MC” user or "root?

Creating a server:
Have you tried just pressing the “create new server” button? Do this create a new server, with the server folders in the right place?

You claim that “profiles do not work for you”. What do you mean by this? Profiles is essential for keeping it easy to create (not import) a server. If you cannot use profiles (for example if the server is kept completely offline) you need to provide the necesary server jars manually by placing them in the correct server folders.

Remember that MineOS is not built or meant to be run as root, but as the MC user. root is only there to do deep system tasks of configuration of the host operating system. Using root for anything else in MineOS will result in unpredictable and unstable behaviour, like servers disapearing, folders not being accessible and so on.

@tNt: No. That would only result in a popup stating that those needed to be filled. The NaNundefinded is due to a problem reading files, either because they are missing, or not generated. I see those error s occationally as well, but then because MineOS had trouble reading my archive location (Since I have my archives moved to a windows share).