Upgrading to 1.12 / Java 1.8 / FreeNAS 9.10.2


#1

My knowledge about FreeNAS / Linux is too limited to get the Upgrade from 1.11.2 to 1.12 done as I’m failing the necessary Java Updated from 1.7 to 1.8.

Could someone provide me with a step by step guide how this is being done for FreeNAS 9.10.2?

  • What do download
  • How to download
  • How to install

The usual Windows Guy questions…


#2

Where are you getting that you are failing the update on JAVA?
Are you just doing an update for minecraft 1.11.2 to 1.12 and you are seeing that it needs JAVA 1.8 in order to update?

This would be a better question for FreeNAS 9.10.2 to make sure that JAVA and where FreeNAS is trying to execute that JAVA from is the 1.8.

Again, this is an assumtion that you are seeing that you cant update Minecraft because it now needs JAVA 1.8 in order to run.

EDIT: I see that you have done that"

So now the issue is how to make minecraft pull the jdk 1.8 instead of the default of 1.7.
Ill see if I can find that and post it back here.


#3

Your help is much appreciated!

For now I’ve pretty much arrived at the same point as OP from another thread:


But that’s about as far as I got as someone not familiar with Linux or coding in general.


#4

Ahh you are referencing this thread:

I dont know if there is a way to update the jave on the jail that you have and then change the location that java is envoked from in FreeNAS. ( I dont have any knowledge of freenas).

But if you can install java JDK 8 into that jail, I would assume you would be able to change it to envoke JDK 8. You would need to change the path that the jail tries to execute java from.

Something like this:
\jails\mineos_1\usr\local\openjdk7\jre\lib
would be like this:
\jails\mineos_1\usr\local\openjdk8\jre\lib

Again, how to do that in the jail with freenas isnt something that I can answer at this time, I dont have any working knowledge of jails and freenas.

If I find something Ill post it here for you to look at.


#5

What worked for me (referenced thread) was going into the jail shell and using: pkg install openjdk8 which ended up installing it and I was able to start a 1.12 server…

if you already have openjdk7 I believe you can also try pkg upgrade openjdk7 and that may work but I don’t recall… I’m also very new to FreeNAS so this may not be the best way to go about it, it’s just what worked for me. I’ll try to help as best I can.


#6

Sorry the late response… Apparently I’m not getting eMail notifications -_-

I gave those suggestions about upgrading and installing a try / another shot:

Upgrading:
root@mineos_1:/ # pkg upgrade openjdk7
Updating FreeBSD repository catalogue…
[mineos_1] Fetching meta.txz: 100% 944 B 0.9kB/s 00:01
[mineos_1] Fetching packagesite.txz: 100% 6 MiB 6.0MB/s 00:01
Processing entries: 100%
FreeBSD repository update completed. 26558 packages processed.
All repositories are up to date.
pkg: openjdk7 is not installed, therefore upgrade is impossible
Checking integrity… done (0 conflicting)
Your packages are up to date.

Testing:
root@mineos_1:/ # java -version
openjdk version “1.8.0_131”
OpenJDK Runtime Environment (build 1.8.0_131-b11)
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

Installing ( in mineos-amd64 folder ):
root@mineos_1:/usr/pbi/mineos-amd64 # pkg install openjdk8
Updating FreeBSD repository catalogue…
FreeBSD repository is up to date.
All repositories are up to date.
Checking integrity… done (0 conflicting)
The most recent version of packages are already installed
root@mineos_1:/usr/pbi/mineos-amd64 #

It’s not budging with those two methods and without a spoon feed guide on how to have it invoke openjdk8 instead of openjdk7 I have no way of giving it a shot.


FreeNAS 11.1 - MineOS upgrading to 1.8 to 1.12.2
#7

For me the fix was simple when I installed MineOS plugin onto FreeNAS 11. It did not work out of the box after enabling the 1.12 Mojang profile. Java version 1.8 was already installed, still the server would not run. After some messing around a light went off from my logfile.

I ran “pkg install openjdk7” at the command line after “pkg update”

Restarted server and was good to go.