Upgrading from turnkey... Help?

I have the old webUI installed… and that update command isnt’ working… How do I get the new mineOS?

I am not sure what is your question, so I can answer a few.

Upgrading from turnkey… Help?

Upgrading from turnkey to… what? Turnkey is what it is.

If you are upgrading turnkey from the turnkey console, it should update itself daily by default or you could try:

apt-get update

Others you could try:

apt-get upgrade

apt-get dist-upgrade

When you do that, what is the reply? Did it say “Invalid certificate” or something?

If you are trying to upgrade the MineOS WebUI the commands used would depend on what distro of MineOS you are using. I understand you have an old one, I do not know what one.

Are you trying to update the Open-JDK 6 or 7 to Java 8? Can try:

sh -c ‘echo “deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main” >> /etc/apt/sources.list’

sh -c ‘echo “deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main” >> /etc/apt/sources.list’

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886

apt-get update

apt-get install oracle-java8-installer

You just want to start over? Back up your Archives and/or Worlds then import them into the latest and greatest distro. You can get the new Jessie w/ Open-JDK8 written in NodeJS here:

32-bit https://my.syncplicity.com/share/ibxt0rrklvogxar/mineos-node_tkl-x86

64-bit https://my.syncplicity.com/share/np9ardmyjiyvvnr/mineos-node_jessie-x64

Good Luck!


You can always download the most recent Turnkey ISO and install it.

First, archive your servers and move them off your host. Then, install the new ISO over your existing OS.

This is what I would recommend as the most straightforward approach, just guessing at your expertise in Linux as being relatively new.

Solved: I just went to Walmart and bought more CD’s to burn to. :frowning:

And then burned the latest version- didn’t work. So I burned the second latest 64bit and it actually worked. Not sure what’s wrong with the first one. Either way, updated scripts, now I’m good to go.

It works for many people; typically you’ll have to provide some greater detail to figure out why.

Well my server wouldn’t read the disk as a bootable disk.