Upgrade Profile for Server

I have an existing Minecraft server running FTBBeyond-1.0.1 profile. I have attempted to upgrade the server to FTBBeyond-1.1.0 profile. I was able to successfully download the new profile, but I cannot figure out how to update the existing server to use the new profile.

I tried using the “Change profile to:” dropdown box and the “Copy profile to live server files” button. Is this documented somewhere that I am struggling to find? How would I go about doing this? I am running on a VM, so I can try and revert as often as necessary.

These are perfectly the correct steps. The only remaining step would be to check the ‘runnable jar’ dropdown for any new entries (or to ensure the existing filename, if unchanged).

Provided that going from FTBBeyond 1.0.1 to 1.1.0 is a drop-in replacement (which should be the case because its FTBBeyond -> FTBBeyond, then the server should start up and the logs should report the new version, as well.

Here is my exact list of steps, assuming the new profile has been downloaded through the UI already:

  1. Shutdown VM
  2. Create checkpoint
  3. Boot VM (Minecraft server autostarts)
  4. Select server in dropdown
  5. Go to Server Status tab
  6. Hit Stop button an wait for web UI to report success
  7. Use “Change profile to:” to select “FTBBeyond-1.1.0”
  8. Hit “Copy profile to live server files”
  9. Hit “Accept EULA” button in the popup
  10. Hit “Start” button in the popup
  11. Server appears to try starting, but ends up reporting that it is down after about 30 seconds
  12. Use “Change runnable jar to:” to select “FTBServer-1.10.2-12.18.3.2254-universal.jar”
  13. Hit “Start” button on the normal UI page
  14. Server appears to try starting, but ends up reporting that it is down after about 30 seconds
  15. Revert VM to checkpoint created in step 2

Any ideas what I am doing wrong and how to fix this?

hi Graznarak,

as indicated by Sir hexparrot above, your steps look good, the mc server should start but it is not.

the log files usually give a great idea on what is going wrong and without seeing them there is only guesswork to be made.

so i make a guess. i did not see you create a new server and just added FTBBeyond 1.0.1 to 1.1.0 expecting some kind of upgrade.

tell me what happened to your mods folder? did the 1.0 mods get added to the 0.1 mods? do you now have two different versions of any same mod name? if so, that is not going to work.

oh, you did make a new mc server? so now you have two, FTBBeyond-1.0.1 and FTBBeyond-1.1.0? are they both running at the same time? do they both use the same port? if so, that is not going to work.

what is your system? how much ram, how many mc servers do you expect to run at the same time? do they each get their own VM or both on one VM?

lots of ideas and guesses, but none work, do they?

lets see the logs please.

cheers!

tNt

forgot to mention, by rolling it back, you erased the logs that need to be reviewed.

good luck!

tNt

I think tNt nailed it on the head. I apologize that my FTB expertise is a bit lacking, but while you can easily change profiles and the runnable jar from the webui, it appears that that workflow isn’t really kosher with FTBBeyond, which does appear to add in 1.10.2 mods with 1.0.1 mods, resulting in an enormous directory which, unfortunately, does not start.

At this point, I think the most reasonable way to handle this is to do the following:

  1. revert (if you choose) to the pre-upgrade attempt
  2. ensure the server is stopped (call it Server A)
  3. create a server archive of A
  4. create a new server from this archive of A (from the archive tab, actions dropdown), to Server B
  5. log into your server via ssh/sftp
  6. delete the Server B’s mods directory
  7. Start the server up.

Basically, we’re looking at the mods being the real conflicting issue here. It also is very likely you can do the steps in this alternative way:

  1. Create a new server C
  2. Assign it profile FTBBeyond-1.1.0
  3. Hit “Copy profile to live server files”
  4. Hit “Accept EULA” button in the popup
  5. Move all the world and player files over with SFTP/SSH
  6. Hit “Start” button

However, this forces a lot more actions to be done in CLI (or your sftp client), which makes it more prone to error (which files do you move?). Both should be valid. This approach might be preferable, however, because of it’s clean slate, but puts the onus on you for copying over the right world and player files.

At any rate, I succeeded just now with the first way I mentioned, up above, so start with that.

Your steps worked perfectly. Thanks!

1 Like