Updated Beginner-Friendly version of MineOS-Node (distro)

Yeah i am having the issue regarding the jar file not being selectable when running 1.12 modded. Trying to run continuum and stoneblock but it always erases the jar file from the server.config file when i try to launch even if i manuallh put it in. Not sure what to dl looked around and idiotically couldnt find an answer.

That’s odd indeed, thanks for shinning in. Maybe the dev of the ported version can have this ironed out for the 18.04 based release.

Other than that I am still wondering how I would go about hosting on a VPS with this as above.

Well, this/my version or release of MineOS-Node on distro is meant mainly if not solely for “new/beginner” and “at home” users, and would actually more than likely not function at all out of the box on a VPS like it would a home user’s computer or a virtual machine. The reason for that isn’t just because of the GUI (which honestly would make a lot less sense in my opinion to have on a VPS) but the default secured firewall configuration does not and will not allow for any remote access whatsoever as by default the only port accessible from the outside is the default Minecraft 25565 port, every other remote/administration port (MineOS Web UI, SSH/SFTP, etc) can only be used or accessed locally via localhost on the machine itself, and in order to change or “fix” that one would need to have physical access to the VPS both during and after installation; if that VPS provider has some kind of remote screen feed thing where you are able to both see and interact remotely with whatever is being shown or displayed on the screen then that would be your ticket or method into changing or “fixing” that to allow for remote access/administration.


Game service providers typically mostly are for people who uhh, either don’t really know how to do it themselves for one reason or another (or somehow don’t know it’s possible for them to just host one themselves as I’ve come across plenty of people who didn’t know) or who won’t notice the difference in performance or lag, etc or for people with tons of money to throw out for a decent performing provider.


Well, it’s similar at times to some game service providers depending upon the VPS provider you choose, so just like with choosing game service providers, sometimes you’ll have sub-par performance thus lag or time out, or you’ll be paying more for something that performs decently typically.


I second that for a VPS due to the reasons above (firewall) in the first portion of this response.


Don’t quote me on this but I believe the latest OpenJDK available to be installed in the default Ubuntu repos currently is OpenJDK8, as for Oracle Java 8 (mods typically tend to crash much less with Oracle Java 8 vs OpenJDK8 based upon some posts here on the forum where the resolution was replacing OpenJDK with Oracle Java), you require a few more additional steps and would also require those same steps with my distribution, except in my distribution it is made much easier to do, as in simply executing “sudo apt-get install oracle-java8-installer oracle-java8-set-default” (or just “sudo apt-get install oracle-java8-installer” by itself) in/via terminal, or a package manager.


Well, typically no not really unless you have more requirements or wants or needs; once you get the web ui installed along with all the other components that it (and Minecraft) makes use of or relies on, that’s pretty much it, anything else is just extra.


I’ve seen that issue around here and there, not specific to my distribution however as the web ui is stock/untouched by me, though I think in the next release I’ll be re-implementing something I had always made use of which is to hide the characters in the password field by default automatically.
Anyways, try renaming your jar file to something shorter maybe, refreshing the web ui, selecting it, starting/stopping the server one time each, refresh the web ui and see if you can start it again without having to select the jar file again.


I would probably have or need to make/create a “less secured” version, which would either have all ports open by default (like on a typical default VPS installation) or would have all administration ports open alongside the default Minecraft server port. I suppose I can keep that in mind for when I build and am ready to release the next upcoming version, to build 2 separate versions one with the local administration only firewall policy and another with the remote administration firewall policy. I still recommend for a VPS just manually installing MineOS’ web ui on top and running/hosting that way. Or actually, I could probably make/create a more VPS/remote optimized version based on Ubuntu-Server that would make a lot more sense to me in my opinion (would be commandline only though, no GUI apart from remote web administration UIs such as the MineOS Web UI), alongside the version/release meant for home use/users, though obviously that kind of ruins the whole point of “beginner-friendly” a bit/lot, and actually would might as well be in my opinion the “official” MineOS distro. I still may look into this however due to the problems/issues with the official distro (mainly namely the USB installation issues and hardware sometimes not working out of the box with the official MineOS distro vs just installing MineOS on Ubuntu Server).

Interesting thanks for addressing my concerns and regarding…

I understand what you means a $2/GB game server or VPS are both likely to be trash. But because of the limited industry objectives (price and performance usually over stability, security, quick support etc etc etc) of Game Service Providers, I feel like with a respectfully paid VPS I can still surpass most game service providers in an overall sense. At the cost of being responsible for it’s inter workings and/or reaching out place(s) like here for additional support.

But as you mentioned I glad to see generally speaking once I properly set it up in accordance to the wiki and keep it updated as per it’s recommendations there won’t be generally issues to worry about it and/or keeping the VPS “on”.

I’ve set up everything I need using the included desktop environment. Now that that’s done, how can I disable the desktop environment and window manager (and anything related that’s also needlessly using ram)?

Thanks for this, by the way; saves me a lot of time!


:warning: Make sure that you enable/allow some form or level of remote administration in your firewall configuration before running in/switching to the commandline only mode :warning:

To make the system boot up into commandline only mode without the desktop environment or window manager, you should be able to just use/run “systemctl set-default multi-user.target” as root.


To revert (making the system boot up back with the desktop environment and window manager again), you should be able to just use/run “systemctl set-default graphical.target” as root.

1 Like

Perfect, thank you!

For remote access, I’ve opened the ports for Webmin, MineOS, SSH/SFTP and additional Minecraft servers through the graphical firewall management application. I’ve been managing the server remotely and everything’s been running smoothly.

If I’m struggling to install from this iso should I post here or in a new thread? #noob #humble

Could be either, I don’t mind here but it could also be a separate thread.

HELP i cant install the os it says no root file is defined. Please corect this form the partitioning menu.

What am i doing wrong pls help me
@JayMontana36

i made it to work somehow

is there a way to make it boot with out the desktop? i want to use this os due to compatibility with newer minecraft versions. but the desktop eats my ram/possessing power so much the server lags/crashes, on my weak computer.

Yes, what you can do is install a server edition of Linux. I personally use Ubuntu for my server and I installed MineOS through apt-get. It works just fine.

Only downside is you need to learn how to do things with only a terminal interface which does take time if you are only a avid user of Linux.

@acrolance & @ovingiv | See this post for disabling the desktop environment/window manager, which happens to be ~5 posts up (using search also would’ve helped).

this may be a silly question for you but idk how to do that? after installation and making sure the fire wall is down with remote administration working… how do i make that run as root?

Pop open a terminal window and perform/execute/run “sudo -i”, and afterwards you will be in a root terminal from there on out moving forwards (for that terminal session);

alternatively, a much faster equivalent that keeps you in your normal terminal session but runs the command as root, is to just simply prefix the command with “sudo”.

Example: command “apt update” will fail without root access/privileges, prefixing said command with sudo ("sudo apt update") will grant root access/privileges for that command allowing it to succeed, and keep you in your normal terminal session. Read up on sudo and root access (Google) for more info regarding it.

Update: I had originally planned to skip 18.04 and do a 20.04 release instead (due to timing that would make no sense to even bother doing/publishing an 18.04 over 20.04) however due to life stuff it is no longer going to happen (at least not anytime soon, I had planned to do it about a week after 20.04 but again life stuff means it will probably be months later unless I get lucky); for those of you however who are wondering, yes this 16.04 release is (or should be) still pretty good/solid and should also be upgradeable to 18.04 followed by to 20.04 (if you really want to) however I’ve not tested so can’t confirm a smooth transition, 16.04 is still solid and officially supported until 2021 with end of life being 2024 so no need to upgrade at all unless absolutely necessary for newer hardware or something (though but even then a newer kernel should suffice for newer hardware). Just wanted to give a heads up since I’ve had a lot going on in my life and it’s been awhile since I’ve been here and I’ve had many questions in regards to updates and whatnot so I figured I’d just let it be known publicly what’s going on with this.


tl;dr this release still is working and supported, there will be no new update or release by me for awhile due to life, upgrading it yourself to a newer Ubuntu release should work but has not been validated as being successful and there’s no reason to upgrade unless you need it on newer hardware (but even then a simple kernel upgrade should solve any “newer hardware problem(s)” after installing), standard updates will continue to work just fine like normal until Apr 2021, Security/Maintenance Apr 2024. Wanted to let everyone know publicly what’s going on with this.

(SOLVED) Hi Jay, I did the instructions like you said but all i get is a flashing line in the top left hand corner on the screen when i boot it up. I tried connecting to it via ssh, (I did all the IP tables and it worked fine before i restarted the computer) and got an get an error. Did i do anything wrong or is this normal.

EDIT: I ended up setting it back to graphical using the recovery mode, however, i’m confused why my ssh wasn’t working.

EDIT 2: So it turns out the IP table edits i did didn’t save so that’s why it didn’t work.

While you can use iptables to configure (override) the firewall’s configuration, in the GUI’s “start menu”, under one of the configuration/system menus, there is a “Firewall Configuration” there, which opens up “Gufw”, which is what is used to configure the firewall for organization, simplicity, and ease. “ufw” stands for “Uncomplicated Firewall”, with the “G” likely standing for Graphical.

I’ve left several presets for you to choose from (all of which can be further customized to your liking), the default being Local Administration Only which blocks off access to SSH and other remote administration service ports, with 2 other profiles for remote administration, one allowing SSH access, the other allowing SSH and Webmin access. In the new version that I was working on over a year ago, there were even more profiles for you to choose from.


Edit: You can also use “gufw” and other applications remotely if the remote PC also runs Linux or you have the appropriate software installed on Windows, otherwise you’d use “ufw”.

What is the root password?

Also, when I login to the MineOS webui and click download latest buildtools.jar or official profile download, it does not do anything. Any ideas?