Update a MC Pocket Edtiion (AKA pocketmine) server after latest Mojang update


#1

The latest Minecraft Pocket Edition made sure the previous versions of the server files we used where outdated again. After a bit of cursing, headcrashing, log-reading and tinkering I got a new version of Imagicalmine to work. I am still not quite sure it is completely stable, and felt it was a bit of touch and go if I got everything up and running. I had to restart my MineOS-server several times to work around things.

This is what I did that finally made me able to get MineOS and Imagical mine to be stable and working toghether:

  1. Downloads:

  2. In all PE-servers: Disable autostart

  • After a restart where Mineos tried to start the PE-servers (I run two of them) the MineOS Web-UI crashed… IF I let Mineos start completely, and start every not PE-server first, I could start the PE-servers one at a time afterwords.
  1. SSH into your MineOS server
  2. go to your server files for the PE-server you wish to upgrade
  • “cd /var/games/minecraft/servers/[servername]”
  1. move the current PHP installation to a backup directory
  • “mv -R bin/ bin.190216” (the numbers are todays date; 19 feb 16)
  1. copy the files you downloaded into your server with your chosen transfer method,
  • just make sure they are placed in the server directory ("/var/games/minecraft/servers/[servername]"
  1. unpack your PHP files
  • “tar -zxvf PHP_7.0.3_x86-64_Linux.tar.gz” (I used the version for 64 bit linux,swap the PHP name for the version you downloaded.
  1. enter the bin directory and copy the php7 directory over to a new php5 diredtory
    • “cd bin”
  • “cp -R php7/ php5/”
  • You should now have two directories in your bin directory: php5 and php7, both containing the php7 runnables. There is a fault somewhere where the server looks in php5 to find the runnable php file, while the php7 versins place all its files in the php7 directory. By copying all the php7/ files to php5/ we fool the system to use the right binaries in the place it expects to find them.
  1. you MAY have to restart the MineOS server, I actually kinda reccomend it, but that is because I had to, so I don’t know if it is really nescecary.
  2. Open the PE server you are updating in MineOS Web-UI
  • set “Imagcialmine.phar” as your runnable server file.
  • You should not need anything in profile, since you have done the same thing the profle does by adding in the PHP files manually.
  1. press start.

And now my servers started.

HexParrot: You will probably read between the lines a few errors I ran into, I haven’t bugreported them, since I haven’t found a good way to replicate the error. I usually run into them while tinkering, so it’s kinda hard to say if it is my tinkering or the server that are at fault… I’ve also skipped quite a few of all the things I did to find a wokring method to get PE working again, so the method above may not trigger anything else (hopefully) than a working server.

I hope this helps. And good luck :slight_smile:


[SOLVED] PocketMine (mineos-node) unable connect on ios or android
Pocketmine install
#2

The latest version of MCPE has a nasty bug where the clients do not properly load chunks from the server. This is for now found to be client-side, and there is nothing we can do serverside.

https://bugs.mojang.com/browse/MCPE-13577

Playing locally (on your own device) works fine, but connecting to another player or server (netwrok play) may (and in most cases) will trigger the bug. This manifest in huge unloaded parts of the map. Some persons have reportetd getting stuck in walls or other blocks that have unloaded and do not reload properly (or at all).

To be clear: This is absolutely NOT a MineOS problem. This is a Mojang and Minecraft P.E.014 problem.


#3

Update:
It seems Mojang has updated the network protocol for MCPE with some new features and methods. Pocketmine and Imagicalmine is working on building new versions with support for the new protocol.

Imagicalmine may have released a version already, but their Jenkins-page is going slugishly, and my download keeps stopping, so I havent been able to test it yet. <-- Tested. Still not OK


#4

In any webui updated from at least February 9, the php7 directory will be detected and favored if found. If not found, it will fallback to the php5 directory.

That should make the need to go in via SSH no longer necessary.

A new ISO I recently released, featuring Debian Jessie (rather than Wheezy) comes with the environment appropriate to run php7 out-of-box. On the Jessie install, the Pocketmine-PHP profiles work immediately. PHP works, of course, but it’s always up in the air with PM or IM work.


#5

Good news, good work, and thank you :slight_smile:


#6

The latest Pocketmine phar have fixed the block-load error. Available here: http://pmt.mcpe.me/pmb/dl/master.phar