Unrecognized service

Tried to do an update of my mineos web interface via: https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui

It seems to have failed as now there is no service mineos running. and my attempts to start it via shell in a box result in root@core games/minecraft# service mineos start
mineos: unrecognized service

Any thoughts? Is there a way I can do a fresh install of just the web ui without the entire os? Any logs I should post?

Thanks.

Have you tried just rebooting the entire server? The WebUI should autostart when the server starts.

Have you tried the command “supervisorctl start mineos”.

I think “service mineos start” is an old command.

Yes, I’ve done a couple of reboots. Nothing seems to happen.

root@core ~# supervisorctl start mineos
mineos: ERROR (abnormal termination)

Then I guess we need the mineos.log (located at : /var/log/mineos.log).

We also need the type of install of mineos you did originally. Was it the old python based WebUI? or is it the newer node based UI?

The older Python versions is the one in the wiki that uses “service mineos start” to start mineos, while the newer node versions use “supervisorctl start mineos”.

updating the webui from one to the other is possible but not straight forward. It is also more of a removal-reinstall prosess of the webui and all dependencies.

As you can see: To be able to give you any meaningful help on this we need more info.

1 Like

Thanks for replying, honestly not sure which version it is.

That log file is completely blank though.

Judging by the age though, since my last install was somewhere around October of last year it should be the newer version

I might as well ask in advance if there is a page that describes the full reinstall of the current version?

What do you have exactly, MineOS Turnkey with the Python-based web ui?

Based on the hostname, this is likely MineOS Turnkey. With that said, if this webui has been up since October, there seems to be no good reason for /var/log/mineos.log to be empty–that’s odd.

Here’s what we can try, and do this command as root:

cd /usr/games/minecraft
nodejs webui.js

We know that the webui service is not running (based on ERROR - abnormal termination), so this should start it up, actively in the foreground.

It should also produce any errors/problems it has starting up right to your screen, which you can copy/paste for us to determine the problem at hand.

I have suspicions of what could have gone wrong, but I couldn’t know without knowing what commands you did execute in order to update the webui – and whether or not any of them succeeded/errorred out.

Thanks for the reply, here’s the response to that command. And yes, sorry. It does say TurkKey Linux at the top of my shell in a box when I log in to root.

My attempts to update were following this

https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui
cd /usr/games/minecraft
git fetch
git merge origin/master
npm install

Thanks for the reply.

Error from :cd /usr/games/minecraft
nodejs webui.js

module.js:338
throw err;
^

Error: Cannot find module ‘/root/webui.js’
at Function.Module._resolveFilename (module.js:336:15)
at Function.Module._load (module.js:286:25)
at Function.Module.runMain (module.js:475:10)
at startup (node.js:118:18)
at node.js:952:3

Are you sure this line executed from the correct directory, /usr/games/minecraft?

Because according to the error, the terminal thinks you’re in /root, instead.

Also, I know the commands you’re trying to execute…I need to know what the hosts responds with…whether it is errors, output of any kind, etc.

Apologies, let me copy the entire thing.
And I too think the error is strange, I’m pretty certain I have that directory when I WinSCP into it.

root@core ~# cd /usr/games/minecraft
-bash: cd: /usr/games/minecraft: No such file or directory
root@core ~# nodejs webui.js
module.js:338
throw err;
^

Error: Cannot find module ‘/root/webui.js’
at Function.Module._resolveFilename (module.js:336:15)
at Function.Module._load (module.js:286:25)
at Function.Module.runMain (module.js:475:10)
at startup (node.js:118:18)
at node.js:952:3
root@core ~#

As a general rule of thumb, if the first command gives an error, you probably won’t get useful results out of the subsequent commands.

Based on your error, the entire directory containing the scripts is missing. Have you…done anything to them? Can you verify these files exist at all?

That would make sense. Apologies for my lack of linux.

Um, actually no. The entire usr/games folder is completely empty when I go to look at it.

Back at the first post, this directory existed. What have you done since then?

history is a command that will list everything you’ve done.

Oh, that’s really helpful. I’ll make a pastebin of this due to length I believe.

http://pastebin.com/p7pqrVhN

I’m a bit confused.

This suggests that you installed the Python version of the webui on your system…a system which presumably should already have had MineOS installed.

git clone git://github.com/hexparrot/mineos minecraft

Also, I see you clone the repo repeatedly, but without any indication of why. You don’t delete the files, you just continue to clone it, as in lines #7, #13, #34

Then, at lines #188, you’re attempting the reset process for the NodeJS version of the webui, then in #193, you’re deleting non-existent NodeJS modules, then in #195 you’re chmodding Python files. Then in #197 you’re running more NodeJS commands then you’re deleting NodeJS in #199 and then installing Python at #201…, then cloning the Python version in #205.

And this goes on and on and on and on.

Since the MineOS webui is already installed by default on a fresh install, there is no need for you to have gone through–multiple times–the installation process. The installation process and the updating-the-webui process are very different. I’m pretty confused by your history here.

While your system, I’m certain, is absolutely salvageable, because MineOS (whether python or node) is easily removable and easily install-able)…I’m inclined to recommend you just…start over.

Back in October, the NodeJS version was already the main MineOS version, and had been for many months prior. That said, you should eliminate all knowledge that the Python version ever existed and make sure to ignore all Python-version related wiki instructions, because what ended up here is kinda…a trainwreck.

I recommend:

  1. copy your existing servers off your Linux host, like to your desktop computer.
  2. count all the servers you have on your MineOS box and verify that many servers exist on your desktop
  3. make sure every server you’ve made on your MineOS box exists somewhere else

You can copy all the files using SFTP, using a client like Filezilla.

  1. Verify all your servers exist on your desktop machine.
  2. Verify all your servers exist on your desktop again
  3. Re-install MineOS from the ISO.

Yes, there is absolutely a way to install this without a fresh install. Typically, that involves like a few delete commands and then going through the very-well tested installation instructions. Again, I’m not really recommending this because your command history is a bit…discouraging that you’ll be able to pull it off. I understand not everybody has the time and experience with Linux that I do, but you should be a little more diligent to pay attention to errors when they pop up instead of just blindly continuing on with the instructions.

1 Like

Kind of what I was expecting, clean reinstall on the way.
Thanks for looking at my train wreck.
Appreciate you taking the time.