Unraid, letsencrypt, MineOS


#1

has any one had any luck using unraid as a OS , using letsencrypt to intall a ssl certificate on MineOS?
i have been at this four about 2 days and i cant find anything online that works. everything i find is ether talking about files and folders that don’t appear in my server or they are talking about a different O.S. i have tried putting different pieces together from different OS / tutorials and i still have no luck. any help would be great:).


#2

I’ve used letsencrypt, and there have been scattered successes on unraid, though I haven’t ever worked with it personally.

As far as the letsencrypt goes, there is a standalone mechanism that allows you to download a properly verified SSL (certbot-auto does it for me). In short, you should be able to get an issued SSL set of files entirely separate from MineOS. From there, we can adjust the MineOS config (/etc/mineos.conf) to utilize that SSL and it should work. Have you been able to get the cert downloaded from the standalone web server?


#4

1 Edit Container:
1a. set config type:

path

1b set container path:

/le-ssl

1c set host:

/mnt/cache/appdata/letsencrypt/etc/letsencrypt/

1d. restart both letsencrypt and mineos dockers

2 Modify the /etc/mineos.conf file
2a. open terminal, SSH into unraid server… then type command:

docker container exec -it MineOS bash

2b. install nano by typing command:

apt-get install nano

2c. Type command cd then type command:

cd …

2d. Then type command:

nano /etc/mineos.conf

2e. replace the config with the MineOS config with:

ssl_private_key = ‘/le-ssl/live/XXX.duckdns.org/privkey.pem’
ssl_certificate = ‘/le-ssl/live/XXXX.duckdns.org/fullchain.pem’
ssl_cert_chain = ‘/le-ssl/live/XXX.duckdns.org/chain.pem’

Note: replace the XXX with your ddns name.

Example: i-love-minecraft.duckdns.org

I will try to make a video once i get the minecrafts.duckdns.org/XXXX to rederect you to mine os using lets encrypt.

this is all thanks to a family member that is working on this with me