Unexplained, inconsistent crashes


#1

I am not certain what category to put this in, so I apologize ahead of time if I made a mistake.

I am one of several admins in a Minecraft community. We run MineOS TurnKey in a virtual machine, with several Spigot servers connected to a BungeeCord server. For a couple of months now, we have had constant, yet inconsistently timed, crashes in all of our Spigot servers that leave no errors in the servers’ logs, but leave hs_err_pid###.log files in the servers’ folders. The owner recently moved the servers to a brand new VM with a fresh installation of MineOS, yet we still have crashes. More recently, we had a couple of crashes in the BungeeCord server as well, after I tried restarting it. And now the servers left a few replay_pid####.log files too. Suspecting that a plugin was causing the crashes, I tried making a fresh test Spigot server without plugins, and it crashed today with no players on. To make matters worse, the entire VM has crashed a few times this past month or did not return after a reboot, which is a major problem since admins cannot restart the machine remotely. I am not sure if these issues are interrelated.

Here are some recent logs:

hs_err_pid17248.log 9/2/2015 9:44:14 PM from BungeeCord:
http://pastebin.com/DVtbB95p

hs_err_pid2834.log 9/3/2015 8:55:38 AM from our Towny_New server:
http://pastebin.com/g8c0jwfA

hs_err_pid2963.log 9/3/2015 7:01:58 PM from our Hub server:
http://pastebin.com/gjNDnn84

hs_err_pid3063.log 9/5/2015 8:48:13 PM from our Test server:
http://pastebin.com/6ghBj5R6

(The replay_pid####.log files are too large for pastebin.)

I don’t know of any logs for the VM or OS.

Even if the issues are not caused by MineOS necessarily, I would appreciate any insight or advice or diagnostic methods that could shed some light on this mystery. Perhaps we have overlooked some crash logs for MineOS? Or is there information in these logs that I missed? Thank you for your time.


#2

On what type of machine is your installation running?

Best,
Jerry
Echo4Golf


#3

now i don’t know the EXACT issue but i do see something that could be causing an issue. not all versions of minecraft are compatible with the 1.8 java. you may want to try your setup on a fresh server vm with 1.7 java and see if this eliminates the problem. also are you using oracle or open jdk i didn’t notice if it said.


#4

We are running an UnRAID 6.1 KVM VM


#5

java -version says:
java version “1.8.0_60”
Java™ SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot™ 64-Bit Server VM (build 25.60-b23, mixed mode)

So we’re running Oracle Java. I will ask the owner if he can test with Java 1.7.
Edit: Another admin downgraded us to Java 1.7. I’ll let you know if it works or not.


#6

I was having similar issues with several VMs and I think I traced it to the paravirtualization settings in VirtualBox. It was unrelated to anthing MineOS or MineCraft. (Again: I think) The machines all seem to have stabilized now that I’ve tweaked the settings so now I’m going to try again with the MineOS and my servers.

Jerry


#7

Another admin downgraded us to Java 1.7.0_80 temporarily, and our Hub server crashed, so I don’t think it helped. But thanks for the idea!


#8

We aren’t using VirtualBox, but which settings were changed to what specifically?


#9

Thank you for trying to help. The computer’s main OS crashed, the owner ran MemTest, and he discovered that these issues were all caused by a defective RAM module. (Or at least, we haven’t had any troubles since the module was removed.)