Unable to start servers as non-root user on CentOS 7

I made a issue on github about this but i am also wanting to see if i can get some help from the MineOS community.
I am running MineOS-node on CentOS 7.

I am unable to start any servers created by a non-root user via the panel. I can however go into the ssh as the non-root user and start the server by command line with no issues at all.

in the panel it just says Start failed 1 in the notification area

here is the output from the logs when i press the start button (no eula popup either and ive also tried setting eula manually to true)

{"level":"info","message":"[test] issued command : \"start\"","timestamp":"2015-12-04T18:59:32.722Z"}
{"level":"info","message":"[test] received request \"start\"","timestamp":"2015-12-04T18:59:32.724Z"}
{"command":"start","uuid":"27839430-9ab9-11e5-93d1-5f14ceea5224","time_initiated":1449255572723,"success":false,"err":1,"time_resolved":1449255572941,"level":"error","message":"[test] command \"start\" errored out:","timestamp":"2015-12-04T18:59:32.942Z"}

Ok, So it turns out to be a bug in CentOS 7 itself.

here is the bug fix for reference for those using CentOS 7

as root use the following commands:

chmod u+s /usr/bin/screen
chmod 755 /var/run/screen

Relevant github issue: https://github.com/hexparrot/mineos-node/issues/153

I’m running into a similar issue. I just migrated my 3 minecraft servers from my Fedora 22 desktop to a CentOS 7 server, however, my Forge and Spigot server started fine, only my vanilla server is failing to start with the same error message you show.

I may try your “fix” but it doesn’t quite make sense. I didn’t have any issues on Fedora and the permissions on screen are the same on both systems:

Fedora 22:
$ ll /usr/bin/screen
-rwxr-sr-x. 1 root screen 479600 Jun 30  2015 /usr/bin/screen

CentOS 7:
# ll /usr/bin/screen
-rwxr-sr-x. 1 root screen 475184 Aug 13 09:39 /usr/bin/screen

I followed the github issue and tried running the full command by hand and it worked. I could even shutdown the server, I just can’t start it from mineos.

Did you run it as root or a non-privileged user, when attempting to start the server by hand?

Check /var/games/minecraft/servers/[yourvanillaserver]/ to see if the files within are owned by root or somebody else.

Yes, because I scp’ed /var/games/minecraft over to the new server I had to go back through and fix permissions, so everything below servers/ is owned by me “richard” and I started the server as “richard”. And the server directory is owned by root but it world writable (777).

Well, I fixed it but not sure why… I forgot to update my rsync to 3.1+. Got that fixed and now I can start the server, why would rsync be needed to start the server? And if it is required, why would my other two servers start fine?


In any case, I did not have to make any modification to screen for everything to work…


Rsync is a required for MineOS, in general. I once considered actually making the webui not even start without the required dependencies to help alleviate this sort of confusion. All the same, rsync is required for copying profiles from their profile directory to the live server directory upon server start (if the files don’t exist).

My best guess for why it worked for the other servers either you SCP’ed the server jars over to their destination.