Unable To Start New Server

I have just set up MineOS Turnkey in VirtualBox. I followed the instructions on how to set it up, I do have access to the Web-UI, but when I create a new server and try to start it, nothing happens. I can give out more details if necessary, sorry if this is really vague.

is there any thing in your log for the server? How about the mineos log? (/var/log/mineos.log)

Can you give us a few more details? ie , what type of server you set?

I am not sure where the MineOS log is, but here is an Imgur link to a screenshot. Also, please help me! I cant stay on the site without going through the DeepWeb. Your site is broken. It wont work at all with chrome.


And here is the one showing me unable to connect using Chrome.


By “Broken” in my last post, I mean, anytime I tried uploading a picture, it would cause Chrome to crash, and then I wouldn’t be able to connect to the site. I have had to go through the deepweb, changing my IP over and over to try and figure out the problem. It is the picture uploads. Chrome works, for now…

The Picture upload problem is not you, it’s the website, i have already confirmed this with Admin.

As for your problem, i see the following problems

You dont have and Xms set , this is needed, it set the minunim memory for your server, you also need to set the Xmx also, this is the max

Example: Xms = 1024 (1g Ram) Xmx = 2048 (2g ram)

What did you set for the Runable Jar?

Also, did you Accept the EULA?, that is Required before any server will start, it should have prompted you to accept it.

Ok since Xmx is at 512, the Xms is at 256. Right now RAM is not an issue, its just a test server. But I set 1.8.9 as the Jar to be used. And I saw in the video, you can click start then a prompt will show up, that has yet to happen. And it still wont launch.

ok 2 things,

First under the profile you chose 1.8.9 , Now click "Copy profile to live server files.
Then Under java settings click the drop down to use that jar.

If you have done that,

Click the “Accept EULA” , that should bring up the prompt for it. if it doesnt work for you , can you try it out in a different browser?

I did get a notification saying the accept EULA was successful. However I still cannot get the server to boot up, I tried doing the copy profile, that didn’t do much.

do you know how to access the backed of the server?

2 things i would like to see,

1 the mineos log , located /var/log/mineos.log

  1. the server.properties file for your server , location is /var/games/minecraft/servers/your servername/server.properties
1 Like

How do I get to either of those? I am using the MineOS Turnkey x64 Iso file. And I also don’t have access to the Webmin. Only Web-UI and Web-Shell.

web shell will work , have used it before? that will get you to the back end.

You just have to navigate to the paths i gave you .

No I haven’t used it, and I honestly have no clue how… This is why I use Windows, Linux is hard to use XD at least for me.


First of:How many Minecraft servers are you planning to run? If you only want MineOS to run one Minecraft server, Mineos is probably not what you need, considering that there are several singel server packs out there that comes with all you need to run it under windows, for most of the iterations of minecraft servers (including pocketmine). For only one server I would advice you to do a websearch and look into that.

On the other hand; If you are adamant that MineOS is the Minecraft Server Manager you need, you also need to learn linux. There is no other way around that, since you at times need to read logs, copy files around, edit files, update, and all sort of other things that the Web-UI can’t do. The Web- UI is only a front end to the daily run of you Minecraft servers.

Take a look at http://www.ee.surrey.ac.uk/Teaching/Unix/ for a linux tutorial for beginners (I promise you , it’s not really that hard, it’s mostly just that you think it is). You mostly get far in admining Minecraft with basic linux commands.

We will off course do our best to help you out, but there are several forum posts in here about how to run MineOS, and several about how to configure and run first time from scratch. All of them have in common that you need to go to the back end and use basic linux commands.

I am trying to host a single server, maybe possibly two. I have used Ubuntu before, and the only reason I am using MineOS is because I have tried using the regular server software in the past. So far nothing else has worked and I have only been able to run a server on my Local Network instead of one that my friends can connect to. But I will look at the Tutorial listed.

I suspect you havent been able to reach your LAN server from the internet due to missing port forwarding.

To be able to run an internet available server, you will also need to set up port forwarding in your internet gateway (or router). MineOS will not be able to do this for you.

In an default network setup a computer (or server) located on a LAN is able to acsess internet. The computer is not autmatically visible on the internet due to something called NAT (Network Adress Translation). This means that when your computer makes request to internet, the gateway keeps track of who sent the request, so that the response is sent to the correct computer. When a request comes from the internet to a local computer, the gateway wil be the default recipient (since the gateway adress is the only one visible on the internet). So for a gateway to be able to handle incoming requests from the internet, you need to tell it which computer on the LAN that are waiting for the request. This is called port forwarding.

Spesifically you need to forward the port 25565 for a minecraft server to be visible on the Internet.

Now, if you want to run more than one server, they cannot all share the same port. They need one port each. So 25565 for the first, 25566 for the second and so on. Each of these ports need to be configured in the gateway, either by forwarding a port group, of by adding each port. by it self.

1 Like

Hi i have port 25565 open on my rougher and port 8080 and 8443 but none of my mates can connet to the mine craft server or the web ui im really lost as to what to do as i really want to use mine os as i can use it on my freenas server and thats really handy but i cant seem to get it to work iv got the mine os ui working and all that and i can see the server and use the ui i got a server set up and “running” but im just lost as to why they cant join if you can help me that would be amazing thanks :smiley:

I still expect a routing error, since everything else is running as it should.

In you router:

  • have you set up your port forwarding like this:

Forwarding alias: Forwarding port: Recipient host: recipient port: type:
Minecraft 25565 [IP adress of your freenas box] TCP

You need to tell your router exactly where to send any incoming requests. If you have a mismatch anywhere (error in port number, error in recipient host, error in recipient port number, error in network adress type (TCP or UDP)) you will not be able to accept conections from the interneT.

I would like to point out that as long as MineOS reports that the server runs as it should, and you can connect on your LAN, MineOS is working perfectly as it should. Everything else is port forwarding, and outside the scope of MineOS. This is wer eyou, as the admin, needs to google and learn to figure out how to make your router and internet connection to allow you to let others connect to your servers.

We’ll try our best to help you, but as far as I can see, this is not an MineOS error.