Unable to start mineos in casaos


I’m somewhat new to mine os. To give some background, I have recently installed mineos using casaos that is installed on top of debian 12. My issue right now is that my server will not start when I accept the eula and press start in the webui. Weirdly enough in the notification menu, it says that the server has been successfully started after I try to start it, however the server remains down. I have tried this all on minecraft version 1.20.6. I would look at the log files and try to trouble shoot from there, but I have no idea where they can be found, as there is no /var/log/mine.os file on my system. I have also checked in other directories to try to find a log file. I have also confirmed that I am running java 17.0.11. Any help on this would be greatly appreciated!

Just been fighting with this. Casa only installs up to Java 18 (well the docker container anyway). 1.20.6 needs JDK21 to run. I am still playing with it but I got it to start from inside the docker container with the following commands

apt install wget
wget https://download.oracle.com/java/21/latest/jdk-21_linux-x64_bin.deb
apt install ./jdk-21_linux-x64_bin.deb
rm /usr/bin/java
ln -s /usr/lib/jvm/jdk-21-oracle-x64/bin/java /usr/bin/java
i was then able to start the jar file directly with java -jar /path/to/jar/file

Im sure there is a better way to fix it permanently but I just started looking into it for my daughter. so if i find more Ill come back and post. Right now though it will start then stop, it no longer tells me any errors about being compiled with a different version of java so I am on the right track.

OK I got it running in the docker container, but i cant tell you for sure all the steps. Part of the problem is just that the docker container hasn’t been updated in a long time. I recloned the repo in from github into the container, updated nodejs, updated many of the nodejs components, java etc. I noticed a few changes in the UI vs the container UI after doing that. It says it is running using Java 1.17.10 but honestly I don’t know if that’s true since I repointed the Java alias etc. Which is one of the UI differences since i updated it shows which java it thinks its using etc. I may try to narrow down which parts are truly necessary but I also created an issue on the container github page who knows if it will every get updated since it looks like its been a couple years.

I may try to build the docker container myself using their dockerfile with a few updates when I get a chance and see if that runs… I am not a docker expert only a dabbler so its a bit of throwing poo on the walls and seeing what sticks…lol

Hey thanks for the reply!

Unfortunately I have midterms that I need to study for, so I wont be able to look at this issue immediately, but I will look at it at some point after tomorrow hopefully. I will definitely be trying what you have done.

Ok so I did experiment with your method, however I did not have any success with it. However I tried another application, crafty, and it worked instantaneously as soon as I installed it. I recommend that you try it out if you still are having problems with mineos.

In the end I think I just did
apt update
apt install openjdk-21-jre-headless
then I checked the java version “java -version” it already had updated the alternatives to use Java 21 and then it just worked. I did clone the git repo for mineos again but I dont think I really needed too to get it to run.

I still want to try to update the dockerfile and build my own updated container just been busy with other stuff. I think the biggest issue with that would be trying to update all the nodejs stuff. Might not be worth the effort since the container uses nodejs 14 vs 20 which I think is the newest and getting all the dependencies updated might be a pain.

i was having the same issue where mineos on casaos would not start servers past 1.20.4 and using crafty worked instantly, thank you for the recommendation