Unable to Start Forge Server

I’m hoping someone might have a solution because this is racking my brain.

I initially wanted to run an RLCraft server but ran into a roadblock. Basically, whenever I tried to start the server it wouldn’t initiate. In the logs, it showed that the command was issued and the request was received, but nothing happened. I tried multiple different suggestions ultimately falling on needing Java 8. I tried many different ways, but I wasn’t able to get it installed properly.

I gave up and decided to run an All the Mods 6 server instead. It was on 1.16.5, which I heard works perfectly with Java 11 (which I was able to install and get working). I am now running into the same roadblock as before. I have tried different jar files, I tried switching back to Java 17, and I even tried an altered version of the suggestion found in the "no targetable jar’ forum post.

I’ve been working on this for a couple of weeks now and it’s really bumming me out. I’d really appreciate if someone with more knowledge could help me out of the hole I’ve dug.

Can you please post your:
contents of your server directory,
your mineos.log,
output from running java -version or java —-version?

Sorry, I don’t know the best way to share the actual files on here, so I put them on Dropbox:
Server Directory
MineOS Log
Server Config

The Java version that I’m currently on is OpenJDK 17, but I’ve also tried everything on OpenJDK 11.

Most of this is at the last point of trial and error. Hopefully it’s just something I overlooked and it’s a simple fix.

Thanks for the help!

A tip for debugging is to use the command line to navigate to the server directory and try running the jar directly java -jar .jar
Running java -version would be handy to prove what version is trying to run the server.
Is this the only server you are trying to run?

It is the only server I’m trying to run. I have been deleting it a few times to try fresh installs between the different test swaps.

In case it matters, I have this server running on a separate machine using PuTTY for SSH and FileZilla for FTP to remote access.

At the time of testing, I did use java -version to double-check that I was using OpenJDK 17 or OpenJDK11. I swapped between the two using update-alternatives --config java. At the most recent time of those logs I was using OpenJDK 17.

As for the debugging, am I correct in this process: Use cd [directory string] with the directory ending in the first break down of the server file, then use java -jar forge-1.16.5-36.2.28-universal.jar to initiate the server load?

Well, the debugging seemed to force the server to start. Although now there is an “Incompatible FML modded server| Server network message list is not compatible” error message popping up client-side. It seems like an actual issue with the mod pack itself not representing certain mods, so hopefully that just requires a reinstall.

Again, thank you, I really appreciate the help!

I was still able to join on mine when it said that.

Where you able to get rlcraft running im having the same issues

I was not able to get RLCraft specifically to work, unfortunately. The main problem I was having was not being able to load Java 8 onto my server. If you were able to get past that part, and are having issues with the server starting up, I would expect that the debugging process should fix that.