Unable to get JAR list on FreeBSD 10.4


#1

Fresh install by the book.
Full internet access for all applications and associated user accounts.

For some odd reason the Profile page reads “No profiles are available; check internet connectivity and refresh the profile list.”

I know I have connectivity.

I tried resetting the scripts and it did not help.

Any Suggestions?

  • Update *
    Upon further hitting it with a hammer, I realized I would completely be happy if I could just manually install a single profile just to get it running. I typically run modded 1.7.10 Forge with forge directly installed in the JAR. I used to run an old old old version of MineOS that way.

Thanks


#2

I have the same issue

I installed the node.js webui on an already running archlinux. So since I can update and download the git repo my physical server has internet connectivity. I can connect to the webui without any trouble.

When I navigate to profiles in the webui it shows the ominous error message: “No profiles are available; check internet connectivity and refresh the profile list.

I didn’t install the server all the way by the book, the webui files are located in /mnt/raid/gameserver/minecraft instead of /var/games/minecraf. but /usr/games does not exist.

thanks


#3

What does the mineos.log show?

Usually it’s in /var/log/mineos.log

Initial guess is this is the issue. Keep in mind that your files don’t need to live in this path, but MineOS would be happy so long as you have these destinations as symlinks.


#4

I started my mineos.service once without the symlink and once with it, but the results seem to be the same.

mineos.log:

{"level":"info","message":"Starting up server, using commit: b68925b fixed issue with mineos_console.js requiring servername for -V\n","timestamp":"2018-07-04T13:34:09.963Z"}
{"date":"Wed Jul 04 2018 15:34:27 GMT+0200 (Central European Summer Time)","process":{"pid":1269,"uid":0,"gid":0,"cwd":"/","execPath":"/usr/bin/node","version":"v10.5.0","argv":["/usr/bin/node","/mnt/raid/gameserver/minecraft/webui.js","start"],"memoryUsage":{"rss":66371584,"heapTotal":24412160,"heapUsed":16205960,"external":943309}},"os":{"loadavg":[0.04296875,0.025390625,0.001953125],"uptime":22787},"trace":[{"column":15,"file":"internal/modules/cjs/loader.js","function":"Module._resolveFilename","line":594,"method":"_resolveFilename","native":false},{"column":25,"file":"internal/modules/cjs/loader.js","function":"Module._load","line":520,"method":"_load","native":false},{"column":17,"file":"internal/modules/cjs/loader.js","function":"Module.require","line":650,"method":"require","native":false},{"column":18,"file":"internal/modules/cjs/helpers.js","function":"require","line":20,"method":null,"native":false},{"column":19,"file":"/mnt/raid/gameserver/minecraft/node_modules/userid/lib/userid.js","function":null,"line":5,"method":null,"native":false},{"column":30,"file":"internal/modules/cjs/loader.js","function":"Module._compile","line":702,"method":"_compile","native":false},{"column":10,"file":"internal/modules/cjs/loader.js","function":"Module._extensions..js","line":713,"method":".js","native":false},{"column":32,"file":"internal/modules/cjs/loader.js","function":"Module.load","line":612,"method":"load","native":false},{"column":12,"file":"internal/modules/cjs/loader.js","function":"tryModuleLoad","line":551,"method":null,"native":false},{"column":3,"file":"internal/modules/cjs/loader.js","function":"Module._load","line":543,"method":"_load","native":false}],"stack":["Error: Cannot find module '/mnt/raid/gameserver/minecraft/node_modules/userid/build/Debug/userid.node'","    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:594:15)","    at Function.Module._load (internal/modules/cjs/loader.js:520:25)","    at Module.require (internal/modules/cjs/loader.js:650:17)","    at require (internal/modules/cjs/helpers.js:20:18)","    at Object.<anonymous> (/mnt/raid/gameserver/minecraft/node_modules/userid/lib/userid.js:5:19)","    at Module._compile (internal/modules/cjs/loader.js:702:30)","    at Object.Module._extensions..js (internal/modules/cjs/loader.js:713:10)","    at Module.load (internal/modules/cjs/loader.js:612:32)","    at tryModuleLoad (internal/modules/cjs/loader.js:551:12)","    at Function.Module._load (internal/modules/cjs/loader.js:543:3)"],"level":"error","message":"uncaughtException: Cannot find module '/mnt/raid/gameserver/minecraft/node_modules/userid/build/Debug/userid.node'","timestamp":"2018-07-04T13:34:27.064Z"}
{"level":"info","message":"Starting up server, using commit: b68925b fixed issue with mineos_console.js requiring servername for -V\n","timestamp":"2018-07-04T13:34:27.723Z"}
{"level":"info","message":"Starting up server, using commit: b68925b fixed issue with mineos_console.js requiring servername for -V\n","timestamp":"2018-07-04T13:35:27.324Z"}
{"date":"Wed Jul 04 2018 15:36:11 GMT+0200 (Central European Summer Time)","process":{"pid":1331,"uid":0,"gid":0,"cwd":"/","execPath":"/usr/bin/node","version":"v10.5.0","argv":["/usr/bin/node","/mnt/raid/gameserver/minecraft/webui.js","start"],"memoryUsage":{"rss":61227008,"heapTotal":22839296,"heapUsed":16247488,"external":1302752}},"os":{"loadavg":[0.0048828125,0.01513671875,0],"uptime":22891},"trace":[{"column":15,"file":"internal/modules/cjs/loader.js","function":"Module._resolveFilename","line":594,"method":"_resolveFilename","native":false},{"column":25,"file":"internal/modules/cjs/loader.js","function":"Module._load","line":520,"method":"_load","native":false},{"column":17,"file":"internal/modules/cjs/loader.js","function":"Module.require","line":650,"method":"require","native":false},{"column":18,"file":"internal/modules/cjs/helpers.js","function":"require","line":20,"method":null,"native":false},{"column":19,"file":"/mnt/raid/gameserver/minecraft/node_modules/userid/lib/userid.js","function":null,"line":5,"method":null,"native":false},{"column":30,"file":"internal/modules/cjs/loader.js","function":"Module._compile","line":702,"method":"_compile","native":false},{"column":10,"file":"internal/modules/cjs/loader.js","function":"Module._extensions..js","line":713,"method":".js","native":false},{"column":32,"file":"internal/modules/cjs/loader.js","function":"Module.load","line":612,"method":"load","native":false},{"column":12,"file":"internal/modules/cjs/loader.js","function":"tryModuleLoad","line":551,"method":null,"native":false},{"column":3,"file":"internal/modules/cjs/loader.js","function":"Module._load","line":543,"method":"_load","native":false}],"stack":["Error: Cannot find module '/mnt/raid/gameserver/minecraft/node_modules/userid/build/Debug/userid.node'","    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:594:15)","    at Function.Module._load (internal/modules/cjs/loader.js:520:25)","    at Module.require (internal/modules/cjs/loader.js:650:17)","    at require (internal/modules/cjs/helpers.js:20:18)","    at Object.<anonymous> (/mnt/raid/gameserver/minecraft/node_modules/userid/lib/userid.js:5:19)","    at Module._compile (internal/modules/cjs/loader.js:702:30)","    at Object.Module._extensions..js (internal/modules/cjs/loader.js:713:10)","    at Module.load (internal/modules/cjs/loader.js:612:32)","    at tryModuleLoad (internal/modules/cjs/loader.js:551:12)","    at Function.Module._load (internal/modules/cjs/loader.js:543:3)"],"level":"error","message":"uncaughtException: Cannot find module '/mnt/raid/gameserver/minecraft/node_modules/userid/build/Debug/userid.node'","timestamp":"2018-07-04T13:36:11.706Z"}
{"level":"info","message":"Starting up server, using commit: b68925b fixed issue with mineos_console.js requiring servername for -V\n","timestamp":"2018-07-04T13:36:12.216Z"}

the dirrctory /usr/games still does not exist.


#5

Webui files are supposed to be in /usr/games/minecraft. This directory will never get create by MineOS, because it’s supposed to be created for the installation of MineOS.

Server files and profiles are supposed to be in /var/games/minecraft. If this path doesn’t exist, you can and should create it. That said,not installing it “by the book” and it not working by not being able to find the profiles seems like they are directly correlated.

I would consider it “by the book” if you were to use all the normal paths, but let the actual files live elsewhere by using symlinks. Just having the symlinks exist (but not be actually used) isn’t of any value.

OPTION 1:

Put the webui files anywhere you want
BUT
ls /usr/games/minecraft should show those files, even if the only reason that command works is because /usr/games/minecraft is a symlink.

Let the server files/profiles go anywhere you want
BUT
ls /var/games/minecraft should show the archive, profiles, backup, etc. directories, even if the only reason is /var/games/minecraft is a symlink.

OPTION 2:

Of course, instead of using symlinks, you can also just update the mineos.conf and init file for your adjusted paths.

MineOS is not in any way hard-coding these directories in the code itself–this stuff is located in /etc/mineos.conf, which can be made to point anywhere (regarding where the latter is saved).

And the startup scripts (presuming you used supervisor_conf.bsd), you can change the path for the webui scripts. Did you adjust these for your nonstandard paths?

LASTLY:

The webui files do not belong in /var. /var is for variable-sized files (sizes change over time during use), which the webui does not. Server files are variable files, so they belong in var. It seems you made a mistake translating the two paths (webui path and file path) into two also separate paths.


#6

Thank you kindly for the help and timely replies. I guess I mixed /var/games and /usr/games up.

So I deleted all my mineos files, stopped running services and started over. Now there seems to be a problem with the npm install command. might be a different issue, but if I ignore it the result is the same (this time I went all the way “by the book” no fancy custom paths.

npm install output:

> posix@4.1.2 install /usr/games/minecraft/node_modules/posix
> node-gyp rebuild

gyp WARN EACCES user "root" does not have permission to access the dev dir "/root/.node-gyp/10.5.0"
gyp WARN EACCES attempting to reinstall using temporary dev dir "/usr/games/minecraft/node_modules/posix/.node-gyp"
gyp WARN install got an error, rolling back install
gyp WARN install got an error, rolling back install
gyp ERR! configure error
gyp ERR! stack Error: EACCES: permission denied, mkdir '/usr/games/minecraft/node_modules/posix/.node-gyp'
gyp ERR! System Linux 4.16.3-1-ARCH
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/games/minecraft/node_modules/posix
gyp ERR! node -v v10.5.0
gyp ERR! node-gyp -v v3.7.0
gyp ERR! not ok
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! posix@4.1.2 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the posix@4.1.2 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2018-07-06T10_16_58_556Z-debug.log
npm install  6.21s user 1.00s system 135% cpu 5.325 total

/root/.npm/_logs/2018-07-06T10_16_58_556Z-debug.log:

0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'install' ]
2 info using npm@6.1.0
3 info using node@v10.5.0
4 verbose npm-session bf604ede45e32211
5 silly install runPreinstallTopLevelLifecycles
6 silly preinstall mineos-node@1.1.1
7 info lifecycle mineos-node@1.1.1~preinstall: mineos-node@1.1.1
8 silly install loadCurrentTree
9 silly install readLocalPackageData
10 timing stage:loadCurrentTree Completed in 872ms
11 silly install loadIdealTree
12 silly install cloneCurrentTreeToIdealTree
13 timing stage:loadIdealTree:cloneCurrentTree Completed in 6ms
14 silly install loadShrinkwrap
15 timing stage:loadIdealTree:loadShrinkwrap Completed in 372ms
16 silly install loadAllDepsIntoIdealTree
17 timing stage:loadIdealTree:loadAllDepsIntoIdealTree Completed in 331ms
18 timing stage:loadIdealTree Completed in 852ms
19 silly currentTree mineos-node@1.1.1
[...]
20 silly idealTree mineos-node@1.1.1
[...]
21 silly install generateActionsToTake
22 timing stage:generateActionsToTake Completed in 36ms
23 silly diffTrees action count 2
24 silly diffTrees add nan@2.10.0
25 silly diffTrees update posix@4.1.2
26 silly decomposeActions action count 18
27 silly decomposeActions fetch nan@2.10.0
28 silly decomposeActions extract nan@2.10.0
29 silly decomposeActions preinstall nan@2.10.0
30 silly decomposeActions build nan@2.10.0
31 silly decomposeActions install nan@2.10.0
32 silly decomposeActions postinstall nan@2.10.0
33 silly decomposeActions finalize nan@2.10.0
34 silly decomposeActions refresh-package-json nan@2.10.0
35 silly decomposeActions unbuild posix
36 silly decomposeActions remove posix
37 silly decomposeActions fetch posix@4.1.2
38 silly decomposeActions extract posix@4.1.2
39 silly decomposeActions preinstall posix@4.1.2
40 silly decomposeActions build posix@4.1.2
41 silly decomposeActions install posix@4.1.2
42 silly decomposeActions postinstall posix@4.1.2
43 silly decomposeActions finalize posix@4.1.2
44 silly decomposeActions refresh-package-json posix@4.1.2
45 silly install executeActions
46 silly doSerial global-install 18
47 verbose correctMkdir /root/.npm/_locks correctMkdir not in flight; initializing
48 verbose lock using /root/.npm/_locks/staging-f7c29c480013c56a.lock for /usr/games/minecraft/node_modules/.staging
49 silly doParallel extract 2
50 silly extract nan@2.10.0
51 silly extract posix@4.1.2
52 silly tarball trying nan@2.10.0 by hash: sha512-bAdJv7fBLhWC+/Bls0Oza+mvTaNQtP+1RyhhhvD95pgUJz6XM5IzgmxOkItJ9tkoCiplvAnXI1tNmmUD/eScyA==
53 silly tarball trying posix@4.1.2 by hash: sha512-R1YLMO0tDKuWVRQfcL3dbfv9LvLmB4W6oh+yE2qwlGG0Otkgz1KDIZjnqcs/v+RZfuvDLpCDZs9MQgbcyjppCg==
54 timing audit compress Completed in 107ms
55 info audit Submitting payload of 20275bytes
56 silly extract posix@4.1.2 extracted to /usr/games/minecraft/node_modules/.staging/posix-d84adb84 (75ms)
57 silly extract nan@2.10.0 extracted to /usr/games/minecraft/node_modules/.staging/nan-dfd55d06 (80ms)
58 timing action:extract Completed in 176ms
59 silly doReverseSerial unbuild 18
60 silly unbuild posix
61 info lifecycle undefined~preuninstall: undefined
62 info lifecycle undefined~uninstall: undefined
63 timing action:unbuild Completed in 1ms
64 silly doSerial remove 18
65 timing action:remove Completed in 0ms
66 silly doSerial move 18
67 silly doSerial finalize 18
68 silly finalize /usr/games/minecraft/node_modules/posix/node_modules/nan
69 silly finalize /usr/games/minecraft/node_modules/posix
70 timing action:finalize Completed in 5ms
71 silly doParallel refresh-package-json 2
72 silly refresh-package-json /usr/games/minecraft/node_modules/posix/node_modules/nan
73 silly refresh-package-json /usr/games/minecraft/node_modules/posix
74 timing action:refresh-package-json Completed in 5ms
75 silly doParallel preinstall 2
76 silly preinstall nan@2.10.0
77 info lifecycle nan@2.10.0~preinstall: nan@2.10.0
78 silly preinstall posix@4.1.2
79 info lifecycle posix@4.1.2~preinstall: posix@4.1.2
80 timing action:preinstall Completed in 1ms
81 silly doSerial build 18
82 silly build nan@2.10.0
83 info linkStuff nan@2.10.0
84 silly linkStuff nan@2.10.0 has /usr/games/minecraft/node_modules/posix/node_modules as its parent node_modules
85 silly build posix@4.1.2
86 info linkStuff posix@4.1.2
87 silly linkStuff posix@4.1.2 has /usr/games/minecraft/node_modules as its parent node_modules
88 timing action:build Completed in 1ms
89 silly doSerial global-link 18
90 silly doParallel update-linked 0
91 silly doSerial install 18
92 silly install nan@2.10.0
93 info lifecycle nan@2.10.0~install: nan@2.10.0
94 silly install posix@4.1.2
95 info lifecycle posix@4.1.2~install: posix@4.1.2
96 verbose lifecycle posix@4.1.2~install: unsafe-perm in lifecycle false
97 verbose lifecycle posix@4.1.2~install: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/usr/games/minecraft/node_modules/posix/node_modules/.bin:/usr/games/minecraft/node_modules/.bin:/home/theo/arm/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
98 verbose lifecycle posix@4.1.2~install: CWD: /usr/games/minecraft/node_modules/posix
99 silly lifecycle posix@4.1.2~install: Args: [ '-c', 'node-gyp rebuild' ]
100 silly lifecycle posix@4.1.2~install: Returned: code: 1  signal: null
101 info lifecycle posix@4.1.2~install: Failed to exec install script
102 timing action:install Completed in 269ms
103 verbose unlock done using /root/.npm/_locks/staging-f7c29c480013c56a.lock for /usr/games/minecraft/node_modules/.staging
104 timing stage:rollbackFailedOptional Completed in 18ms
105 timing stage:runTopLevelLifecycles Completed in 2416ms
106 silly saveTree mineos-node@1.1.1
[...]
107 verbose stack Error: posix@4.1.2 install: `node-gyp rebuild`
107 verbose stack Exit status 1
107 verbose stack     at EventEmitter.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:304:16)
107 verbose stack     at EventEmitter.emit (events.js:182:13)
107 verbose stack     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
107 verbose stack     at ChildProcess.emit (events.js:182:13)
107 verbose stack     at maybeClose (internal/child_process.js:961:16)
107 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:5)
108 verbose pkgid posix@4.1.2
109 verbose cwd /usr/games/minecraft
110 verbose Linux 4.16.3-1-ARCH
111 verbose argv "/usr/bin/node" "/usr/bin/npm" "install"
112 verbose node v10.5.0
113 verbose npm  v6.1.0
114 error code ELIFECYCLE
115 error errno 1
116 error posix@4.1.2 install: `node-gyp rebuild`
116 error Exit status 1
117 error Failed at the posix@4.1.2 install script.
117 error This is probably not a problem with npm. There is likely additional logging output above.
118 verbose exit [ 1, true ]

117 error Failed at the posix@4.1.2 install script seems to be the main contributor. running npm as root I don’t know how gyp WARN EACCES user "root" does not have permission to access the dev dir "/root/.node-gyp/10.5.0" should be interpreted.

directories seem well in order now.


#7

Posix npm module seems to have issues on BSD because of the default compiler (which I believe is CLANG). On FreeBSD, you can force c++ to be used with this command from the github repo page README.

echo "CXX=c++ npm install" | sh

It says ‘for this command “npm install” instead use the c++ compiler’. I believe posix should build successfully after this. You may also want to clear out the previous stuff built with rm -rf node_modules which contains modules built with the CLANG BEFORE rebuilding.