Unable to get 1.10 update for spigot

how do I fix this problem where I only can get 1.10 update for vanilla but not for spigot 1.10
ive tried downloading the vanilla 1.10 and still no results
ive tried logging off and logging back in and still spigot 1.10 hasn’t appeared

I tried that but it didn’t work but remember I can get 1.10 vanilla profile but not 1.10 spigot

What @tNt was saying to do was update the WebUI and the system, however since you say it didn’t work, you may try resetting the WebUI instead using these commands from the wiki as root:

cd /usr/games/minecraft
git fetch
git reset --hard origin/master
rm -rf node_modules
npm install
chmod +x mineos_console.js

Then either restart the WebUI service or reboot the system and check to see if it’s there.
PS: The commands @tNt listed should’ve been run as root, as well as the ones shown in this post (but don’t do both of them, just try the reset script instead).

EDIT: I can verify that simply updating the UI scripts work; I’ve just updated to the latest commit (honestly I don’t really touch the UI anymore, as it’s gotten to the point where it’s basically self managing all my servers via crons but I guess I also need one to keep the UI up to date).

error no such file or directory
I tried cd usr/games/minecraft and it says no such file or directory found

You made a mistake;

You forgot the “/” in front of usr; the difference with that is that without the “/” in the beginning, it will attempt to browse for sub folders in the current directory (typically “/home/[username]/”) instead of beginning from the root directory, located at “/”. As an example, typing cd usr/games/minecraft in the default directory would have it trying to locate /home/username/usr/games/minecraft/, (which doesn’t exist, nor should you create it as there is no reason to) instead of going to /usr/games/minecraft.

PS: It’s all copy and paste friendly.

1 Like

oh thanks for solving my mistake I did thank you now I can get 1.10 spigot