Unable to connect via external ip


#1

I have recently created a minecraft server and wanted to allow other people to join. I am able to join just fine through my LAN, but I cannot connect using the external ip. I felt for sure that I had forwarded it correctly, however it is not working. I’m attempting this using the Cisco DPC3941T Xfinity Router just in case that matters. I’ve also checked to make sure the port was open using http://www.ipfingerprints.com/portscan.php, and I’ve checked to see if the firewall was blocking it. I’m not too positive if it is or isn’t, so hopefully someone can help me.
2
1

(imgur link incase the images don’t upload correctly: https://imgur.com/a/Ib4tpmL)


#2

Which of the IP adresses do you use to connect to the game externally? 10.0.0.107, or 73.203.151.125

What kind of minecraft client are you trying to connect with? (pocket edition (including win10 mrakteplace ed). vs java edition)

What type of minecraft server are you trying to run? And have you tried with a vanilla server to see if that works?

Do the minecraft logs say anything about the connections?


#3

73.203.151.125

Java edition

Trying to run a paperspigot server. I have tried to run a vanilla server, but I had the same issue with not being able to connect outside of the LAN.

No, the logs say nothing about the connection.
A picture of what it says whenever I attempt to use the external IP:
4


#4

W/O actually connecting, simply adding your IP (73.203.151.125) to my minecraftclient, I can see your server is up and available (two users connected). Testing the connection my ciient connects (and kicks me out due to whitelisting, good :wink: ).

As far as I can see your server is up and running, and available.


#5

Oh geez, thanks for letting me know that! I suppose it’s an issue with my personal connection then. Glad that it’s working outside the LAN


#6

Just a heads up, in some cases, routers may have a function or feature enabled called Filter WAN NAT Redirection or something along those lines which will basically not allow you to use your Public IP from within your LAN; it can typically be located or found under Security and/or Firewall (or something else along those lines) and would likely be the reason why you are unable to do anything having to do with your Public IP from within your LAN.