UI not showing server types but UI is up to date


#1

So i have used the apt-get system to install a mineos server onto a old pc i had on top of a Linux Ubuntu server. I have been having this problem trying to make a server where everything works accept i can make a new server on the web Ui i followed the update tutorial and i get a bunch of errors when i run the nmp install command. Can someone help me? I am new to Linux servers. Also i am having trouble SSH ing into the server locally using PuTTY. I have a feeling i might of missed a step becuase it is returning file not found errors also when trying UI updates. Thanks!!


#2

The best way to help solve the errors is to know what the command is you’re running, and the errors you’re getting.

What IP address are you connecting with (e.g., the settings in putty) and what’s the error you’re getting?

What command and what user are you using when trying to update? What are the exact errors?


#3

i am getting the connection refused error for putty and the file it is failing to find is config_webui.sh and update_webui.sh which return when i attempt to edit or run them. Thanks for responding!


#4

To best help you, go ahead and copy paste the full complete command (and the prompts, too) as well as the output.

The solutions are only really certain when we know exactly the error we’re dealing with, less so if it’s paraphrased.

When you get ‘connection refused’–are you using the local IP address that is listed in the console (when it boots)? Or are you using your modem’s public IP address.

Once again, these problems are pretty common problems but I’d say 9/10 times we can catch a simple slip-up very easily so long as we know precisely what you’re doing when you get precisely an error.


#5

so when i run the web ui update command as on the wiki i get the command back “/bin/bash: update_webui.sh: No such file in directory” so i assumed then i would have to do it the second older way listed. so knowing i’m still in the same directory i run sudo git fetch and i get a quick hesitation and the promt comes and no error. so I then run git merge origin/master and it says that it is already up to date. But when i go on the ui and log in with a non root account user and make a server I have the classic out of date no server profiles showing up problem. Thanks 20a02!


#6

Right now im updating git


#7

Have you successfully updated the repo? If so, confirm (via /var/log/mineos.log) the issue is reproducible–if you successfully updated the webui/restarted the webui, the log will also report what webui version you’re on.


#8

I don’t have anything on the server at the moment so i am going to try a fresh Linux server reinstall and go over the apt get method carefully and patience, and it i have any problems after that along with any reoccurring problems ill will get back to you. (I am almost sure i ignored a major error previously in the install). Thanks so much!!


#9

OK new report so i fresh installed the server and everything is running now i just need help with little things like what port i use to ftp into the server with filezilla and how to accept the eula (I am having trouble with that) but if you can help me with those things i would be very great full. Thanks!!


#10

Use SFTP, it’s an open port already used for SSH. Filezilla supports this protocol and it will use your webui login (don’t use root).

Pushing the button in the webui should be sufficient. You can verify it by check the contents in SFTP (or make the change in SFTP if you prefer).


#11

Everything is working i can log on but is just still don’t quite know what you are saying about SSHing in an SFTP i just need t know exactly what i need to do.


#12

Treat SFTP just like FTP. There is no FTP server on MineOS Turnkey, nor is there an FTP server on most Linux distros. It is very secure and almost every linux distro uses SFTP. In addition, it is on by default, so this is why it is most recommended.

SSH is a terminal session, like you’d see using PuTTy. It connects using your webui username/password on port 22.

SFTP is just like FTP, like you’d see using FileZilla. It connects using your webui username/password on port 22, too.

Edit (sorry put 21)


#13

Ok going to try that i was trying from port 22 not 21.


#14

Nope, that was a typo! It’s port 22. When you were trying on port 22, was it not working?

I simply meant that SFTP and FTP are pretty much exactly the same in how they operate–they’ll use the same clients (such as Filezilla), have UIs, etc. SFTP is essentially the secure version of FTP, and thus uses your normal username and password for logging into SSH.


#15

ok so 22 and 21 both don’t work still but could i have to do with the fact i have a modem and a vpn switch? beacuase that is the only thing i can think of…


#16

You can start checking the firewall on your MineOS server. is that one set up to allow traffic? If you run a standard installation Ubuntu Server your firewalls is probably configured to accept all, since that is the default config at install time.

As long as you are on the same local area network (LAN) your modem and switch should have no impact. You then use your MineOS servers local IP address and port 22 to connect both SSH and sFTP

If you are on two different networks you need to configure routing and/or port forwarding in the gateway between the networks. You may also need to configure any firewalls between your client and your MineOS to allow connections.


#17

At this point, I don’t even know if you’re trying to connect from within your network or outside your network.

Have you tested any of these services when within the network?


#18

so im trying to connect from the network through a wired connection and it does not connect.


#19

Okay, but what are the values you’re filling into all your SSH attempts? Is it the local IP? I asked you this already above:

This is rudimentary, non-MineOS stuff connecting to your server with SSH. If this is failing, there is zero you need to be concerned with the webui and such; successfully SSH-ing to your Ubuntu installation is key here.