[Tutorial] PreBuilt Minecraft Servers project on SourceForge

Hello all, just wanted to let you know that there’s a PreBuilt Server project on SourceForge that I started on May 11, 2014 (it did exist before that, just not on SourceForge). This was originally intended for people who are new to hosting Minecraft Servers (generally people who don’t exactly know how they can create their own server) and/or don’t have enough system resources to host a server. The SourceForge project has servers as far back as 1.6.4 and are split up into different “Seasons”. Season 1 contains 1.6.4, 1.7.2, 1.7.4, 1.7.5, 1.7.8, and 1.7.9; Season 2 contains 1.7.2 and 1.7.10; Season 3 [BETA] contains 1.7.X-1.8.X (a.k.a. supports all 1.7 and 1.8 clients). Then I abandoned the project for 7 months and have decided to continue the project, skipping Season 4 and a bunch of possible version numbers, making the current build (at the time of writing) version 126 in Season 5 (for 1.8.X only).

What this has to do with MineOS is that this build was made for use with the MineOS WebUI (while maintaining usability on Windows systems as well as others). This actually runs on 256MB RAM with a high/decent TPS!

Screenshot taken from a computer running Windows 8.1

Here is a link to the SourceForge Page for those who want to check it out: https://sourceforge.net/projects/jm36servers/

And here are links to my Official Web: www.jm36.tk | www.jaymontana36.tk or just click on the link from the SourceForge Page if those two don’t work.

Steps required for usage with MineOS (Copied from README file):

 - - - Starting Server on Linux (MineOS Web UI) [Best Method | Recommended | Easiest | Featured]
 - - Step One: Installing the PreBuilt Server's Required Files
 - Simply copy/upload the "Server" folder into the "/var/games/minecraft/servers" folder. When complete, proceed to "Step Two" below.

 - - Step Two: Preparing the PreBuilt Server for use:
 - Before you start the server, you MUST first goto the "server.config" section of the WebUI and set/change "MaxRAM" to the amount of RAM you want the server to be able to use (most people like to set this value to the max usable RAM in their system, minus 256MB). Then goto the "Manage Profiles" section of the WebUI, click on "Create Custom Profile". Enter the following information: [Profile Name: JM36] | [type: unmanaged] | [Jarfile to run: JM36.jar] then click submit.

 - - Step Three: Starting the server (you should already know how to do this, as it's self explanitory):
 - Goto the WebUI "Dashboard", click on "Server", and click "Start". Important note: The first time you start the server may take awhile before it's ready to use, as it needs to download a few files which were left out to make the file size much smaller, as well as generate some default databases and configs (which were removed because they're default; no changes were made to them). Have fun and Hope you enjoy the server!

Note that you can substitute step one if you downloaded the ZIP version of the package by uploading that ZIP into “/var/games/minecraft/import” then from the WebUI, create server from archive.

How to set ranks (also from the README file):

Permissions System:
PermissionsEx (PEX); there are a few predefined ranks: Member (Member), VIP (VIP), TStaff (-Staff | TrialStaff), Staff (Staff), HStaff (+Staff | HeadStaff), TBuilder (-Builder | Trialbuilder), Builder (Builder), HBuilder (+Builder | HeadBuilder), Co-Owner (Co-Owner), Owner (Owner).
To set yourself as Owner, copy and paste the following in console: "pex user <username> group set Owner"
To add people as another rank, type "/pex user <username> group add <grup>"
To see the list of permissions a group comes with by default, head over to https://sites.google.com/site/jaymontana36jasen/server/ranks

Oh and I will be making a step-by-step- guide on my Forums when I can, along with a video on how to do it when I can, and then I will update this post with the same information. Have fun!


I got these to work on mineos-node simply by putting it in the /var/games/minecraft/import/ directory. Works like a charm.

Just tried to install this, did the import step , however i don’t see a profile or jar file to choose for it. Where am i going wrong?

There is a ‘bug’ with MineOS-Node where it simply extracts the zip’s content to the server directory, unlike MineOS-Python where it would “auto-detect” the directory and extract it right.
When you browse to /var/games/minecraft/servers you should see your server name there, but after opening the folder, you will notice a folder inside named “Server”.
What you have to do is copy/cut the contents from the “Server” directory and put the files in your server’s root directory (/var/games/minecraft/servers/[YourServerName]).

If there really is a “bug”, do you have instructions for me to reproduce this, hopefully with an actual archive? I have implemented into both MineOS-python and MineOS-node code that I have successfully used to detect this behavior and to move the server files up a directory, when applicable.

It works 100% on archives I’ve made and used, but again–if there is a specific case, an archive I can work with, I can make sure it works for everybody.

Both MineOS-Python and MineOS-Node create archives of the root directory of a server, however MineOS-Python supported importing servers within archives that has the server located in a folder

For example: When both MineOS Node and Python creates an archive, it’s layout is [Archive]/[ServerContents]. However, Python was able to import archives with a different layout, such as [Archive]/[Folder]/[ServerContents] (which is the format being used with the project) that MineOS-Node wasn’t able to properly import when tested.

The link to the latest/last update to the project is here, which you can simply drop in the Import directory to try importing from within the WebUI. Testing with Python works, but does not in Node.

I’ve just tested it again now, but it still doesn’t correctly import. I could always upload one made specific for MineOS’ UIs (which would actually be an archive made from the UI itself) but I still need to update the project regardless.

I’ve just released an updated version (v145) using the same archive formatting as previous versions, just so you can still test and work on the bug…I mean it’s a minor bug, which is why I never bothered to mention it before. I’ve also updated/added directions for how to install it within MineOS-Node within the Archive’s README file (which users of MineOS, and experienced users generally didn’t need to read).

Fixed this issue with the most recent commit.

Very easy to fix and solves an issue that you specifically had with your file, but also certainly could have affected many others struggling to import.

At any rate, no bug is too small to report, so next time please don’t hesitate to report improper operation; I want this webui working perfectly!


I guess it took a dummy like me to bring it up :slight_smile: . Glad is seems to be straighten out. Maybe now newbies like me can continue learning. Thanks guys for all your dedication to this project.

1 Like