Turnkey WebUI Not Working


#1

I was attempting to get Turnkey working off a ESXi instance using this install guide https://www.youtube.com/watch?v=3JwuFZ0jKE0
I set it up and gave it a static ip of 192.168.29.11 which gave me a screen that said where to access everything 192.168.29.11:8443, :12320, :12321. I was successful in getting to the shell in a box :12320, and the webmin :12321 but unable to get to the webui from https://192.168.29.11:8443 or http://192.168.29.11:8443 from the shell in a box

I can ping 8.8.8.8 and my gateway 192.168.29.1 and they both respond fine but when I attempt to ping 192.168.29.11 from another machine it times out.

I tried updating WebUI
cd /usr/games/minecraft
/bin/bash update_webui.sh

and

cd /usr/games/minecraft
git fetch
git merge origin/master
npm install --unsafe-perm

Which at least seemed to run fine…


I found this link for what it may be and tried
supervisorctl status minos
and got back
mineos FATAL Exited too quickly (process log may have details)

It could be unrelated but I checked /var/log/mineos.log and it came with
Script execution started on: Sat Feb 23 02:25:03 UTC 2019
Updating mineos-node repository…OK
Pulling master branch… Already up-to-date.
OK
Updating npm dependencies…OK
Setting node javascript files to executable…OK
Script execution ended on: Sat Feb 23 02:25:10 UTC 2019

after this still no result getting in but both the shell in a box and webmin still work

EDIT: changed time to today not tommorow and rebooted and now it is working… Yay?