Trying to setup a modpack server

Firstly let me say thanks for mineos and all your hard work!

I am trying to create a new server running the modsauce modpack from ATLauncher. I have it uploaded and it runs from the launcher shell script fine. I just need a nudge in the right direction with the mineos server config.

Working launcher command is:

java -Xmx2G -XX:MaxPermSize=256M -jar forge-1.7.10- nogui

Current server.config (not working) is:

backup_interval =
archive_interval =
restart_interval =

java_xms =
java_xmx = 2048
java_tweaks = nogui
xx:maxpermsize = 256M

start = false

profile = HermitcraftModsauce_1000

And the profile is:

save_as =
run_as = forge-1.7.10-
ignore =
url =
type = unmanaged

Thanks in advance for any assistance.

Have you used the wiki page for Forge to help assist in installing?

Nothing about what I see in your profile seems to be wrong–it should likely work (presuming the installserver portion was completed). Though one thing: the xx:maxpermsize = 256M won’t work: that part belongs in java_tweaks. MineOS doesn’t know (or deliberately ignores) any other [java] attributes; it couldn’t possibly know where to plug it in in the command line, whether before or after this or that, or as a jar-argument or a java-argument. Thus, maxpermsize should be removed as its own line and added to java_tweaks.

Though I can’t check it right now, I suspect that it might even be that line preventing it from working (maybe). xx:maxpermsize is not a valid attribute name, so it could mess up parsing. The first thing to do would be to remove that line entirely and see if you can get the server up and running. Seeing a successful startup, then you can start tweaking java flags.

Hey pybe!

I have a Modsauce server running like a charm since friday night.

Just for comparison. My server.config looks like this:

backup_interval = 60
archive_interval = 0
restart_interval =

java_xms = 256
java_xmx = 27000

start = false

profile = forge-1.7.10-

And my profile looks like this:

save_as = forge-1.7.10-
run_as = forge-1.7.10-
ignore =
type = standard_jar
jar_args = nogui

I think it has something to do with the type parameter in the profile file.

And you have to set “level-type=BIOMESOP” in the before you start the server the first time. “generator-settings=BIOMESOP” alone didn’t worked for me. Although the modpack says so.

Hope i could help you.