Trying to add a previous server

So I made a server on MineOS a while ago and saved a copy of the server file to my desktop. Then like a day later it suddenly disappeared when I rebooted the server. So I did a fresh install of MineOS and now i’m trying to make a server and import the server file I already have. I already tried to replace the worlds, but I kept getting like a permission error. I also tried to put it in the import and create a server via archive, but whenever I would enter a name and click, “create server”, nothing would happen and it wouldn’t show up in the dashboard. However the server status would show up, but I can’t change the .jar so I can’t start the server. I’m honestly lost and I’ve been trying this all week and need some new ideas. Thanks

Are you using filezilla? If you are then what I would recommend is going to var/games/minecraft/servers and dragging the whole file (not just the world) into the servers file. If this doesn’t work then try and create a server with the mineos web interface and make sure it is the same name as the server you are going to copy. As soon as that server is created make sure that it isnt running and drag all the files from inside the copied server file into the server you just created, replacing all the files you had originally.

I am using Filezilla. When I drag the whole file in the server folder it won’t even show up in the dashboard so I can’t turn it on. I also tried to make a new server, then delete all the files in it and then put all the old server files in it, but when I try to turn it on it doesn’t say anything in the logs and just says its down.

I also tried to replace just the “world” file in the new server with my old server. The logs just say:

Preparing level “world”
[02:55:14] [Server thread/INFO]: [STDERR]: ./world/session.lock (Permission denied)
[02:55:14] [Server thread/INFO]: [STDERR]: at Method)
[02:55:14] [Server thread/INFO]: [STDERR]: at
[02:55:14] [Server thread/INFO]: [STDERR]: at
[02:55:14] [Server thread/INFO]: [STDERR]: at
[02:55:14] [Server thread/INFO]: [STDERR]: at coo.h(SourceFile:87)
[02:55:14] [Server thread/INFO]: [STDERR]: at coo.(SourceFile:51)
[02:55:14] [Server thread/INFO]: [STDERR]: at coq.a(SourceFile:113)
[02:55:14] [Server thread/INFO]: [STDERR]: at coq.a(SourceFile:109)
[02:55:14] [Server thread/INFO]: [STDERR]: at net.minecraft.server.MinecraftServer.a(SourceFile:352)
[02:55:14] [Server thread/INFO]: [STDERR]: at uk.d(SourceFile:218)
[02:55:14] [Server thread/INFO]: [STDERR]: at
[02:55:14] [Server thread/INFO]: [STDERR]: at
[02:55:14] [Server thread/ERROR]: Encountered an unexpected exception
java.lang.RuntimeException: Failed to check session lock, aborting
at coo.h(SourceFile:95) ~inecraft_server.1.14.4.jar:?]
at coo.(SourceFile:51) ~inecraft_server.1.14.4.jar:?]
at coq.a(SourceFile:113) ~inecraft_server.1.14.4.jar:?]
at coq.a(SourceFile:109) ~inecraft_server.1.14.4.jar:?]
at net.minecraft.server.MinecraftServer.a(SourceFile:352) ~inecraft_server.1.14.4.jar:?]
at uk.d(SourceFile:218) ~inecraft_server.1.14.4.jar:?]
at inecraft_server.1.14.4.jar:?]
at [?:1.8.0_222]
[02:55:14] [Server thread/ERROR]: This crash report has been saved to: /var/games/minecraft/servers/SMP/./crash-reports/crash-2019-09-16_02.55.14-server.txt
[02:55:14] [Server thread/INFO]: Stopping server
[02:55:14] [Server thread/INFO]: Saving players
[02:55:14] [Server thread/INFO]: Saving worlds
[02:55:14] [Server thread/ERROR]: Exception stopping the server
java.lang.NullPointerException: null
at net.minecraft.server.MinecraftServer.a(SourceFile:546) ~inecraft_server.1.14.4.jar:?]
at net.minecraft.server.MinecraftServer.m(SourceFile:574) ~inecraft_server.1.14.4.jar:?]
at uk.m(SourceFile:593) ~inecraft_server.1.14.4.jar:?]
at inecraft_server.1.14.4.jar:?]
at [?:1.8.0_222]

I don’t know why it doesn’t have permissions or how to give it permissions, but it’s the only file with the “root root” Owner/group thing. Everything else is “mc mc”.

Okay I see whats going on here. MineOS sometimes has this problem where it won’t show servers on reboot. Let me guess, you didn’t have start server on boot selected. To fix the problem you create a new server with the jar file you used (if your server was 1.14.4, then start it as 1.14.4), as soon as the server boots you should be able to see all your servers. Now since you did a reinstall this server is no longer in the backups or archives, so what I’d recommend now is creating a new server, and replace everything inside the “world” file with everything in your world folder that you have backed up. The easiest solution that I can think of (if the methods I’ve provided don’t work) is to download a plugin to import the world such as multiverse.

Ok so are you saying I should make a server, then make a 2nd server. Then put replace everything in the world file on the 2nd server with the old server world files? I’m not sure how creating the first server does anything. Sorry, i’m a bit confused on the wording on your reply.

Like could you do a step-by-step explanation and pretend like I have 0 servers on mineOS so far and I have the old server files on my desktop?

The most beginner friendly way to fix this is creating a bukkit/spigot server with the version you’re using and downloading the plugin multiverse to import a world. I understand why MineOS wasn’t showing your server but I don’t understand why it wont allow you to replace your world. Hopefully the plugin multiverse will help you out.

So I tried doing that but for some reason the first world it spawned me in was my old world with all my gear and stuff. However it’s as if it was the very first game day, no buildings, all stuff gone except whatever we kept in our inventories.

Try deleting that spesific file as root, then try to start the game. The game tries to set up a session, and are prevented from reading or writing to that file. This causes java to fault out.

Log in with your default user, then use “sudo -s” to gain root access.

Other than that, the reccomended way of importing servers is to put the archive in the import folder, then use the “import server” function of MineOS. This will lett MineOS create any files it need, and place files where it needs them.

I put the old server file in the “import” file and deleted the lock thing. However whenever I go to mineOS and create a server from archive, I can click it and choose a name, but when I do it doesnt show in my dashboard or in my “servers” file. i do see the server status bar and stuff and when I try and change the jar, nothing shows up and I’m not able to start the server.

This happens because you don’t have the server set to “start server on boot”. I don’t know what causes this but it happens quite a lot for me. Start a new server with the same jar you used and call it whatever you want to call it and then your server will magically pop up in the list of servers, make sure you have it set to start on boot so you wont have to worry next time

Nope, I always did that with all of the times I’ve tried anything in this forum. Thanks though