(TrueNAS) Server 'Start' Button Does Nothing

Hey all! Before I get into the story, here is what I am working with:
64bit System running TrueNAS Core, with MineOS plugin installed
1.15.5 Spigot Server Jar (with many plugins)

And I have read a few other discussions with the same issue, the start button not working. But because I am running this as a TrueNAS plugin, none of the solutions I found helped.

I’ve been running this server for about a year off of my laptop, been running just fine. I just got a NAS with TrueNAS, and thought it would be neat to run the server there too, so I installed the MineOS plugin. I zipped my Server folder, dropped it into the var\games\minecraft\import folder. I imported the server, used the Spigot profile and Jar to run it, and the server does not boot.

It has to be something to do with Spigot, perhaps the Build.Tools.jar file that it installs. Because when I run a fresh Vanilla or Paper server, it works just fine. But even when I try to create a new server with Spigot, it does not run. And I do see this in my log file:

{"level":"error","message":"[WEBUI] Server was unable to download file: https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar","timestamp":"2021-04-07T15:01:24.871Z"}

I would just open the server folder in var\games\minecraft\servers, drag and drop the old server in, but because I am running this on a NAS, TrueNAS does not allow users to edit plugin files. (I am currently trying to solve this to see if that can work, but outside this solution, I am not sure what to do.)

Thanks for the help!