Trouble With External Connections

I have MineOS setup on FreeNAS with the plugin. I have everything set up to where I can locally access the Minecraft server. I also have port forwarding set up as well, but it seems not to work correctly. I have the port set to ‘25565’ and it’s directed to the FreeNAS device itself (there was no option to direct it to the MineOS jail, unlike Plex). When I go to ‘Multiplayer’ in Minecraft, the server appears as running with a ping of 4, but when I try to join, it says ‘Connecting to the server…’ for some time, then I get an error that says ‘io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection timed out: no further information:.’ Sometimes, if maybe I’m in the menu to change a server’s name or IP in Minecraft or alt-tabbed out of the game (just after canceling the connection to the server/during the connection process), it will put me into the game. After failing to join, I also refresh the server list in the game, and then Minecraft tells me that it can’t connect to the server. I really need help because I’m confused on how the port forward SEEMS to work, but doesn’t at the same time. Also as a side note, my friend tried to join the Minecraft server and he couldn’t. If you need any more info or details, I will try to provide them.