Trouble installing MineOS onto Ubuntu Server

I recently installed MineOS onto a VM and liked it. Today I made a bootable USB with Rufus to install it to an older PC I have and it didn’t work. I kept getting the error “unable to find a medium containing a live file system". I found some posts on this forum that basically said to get Ubuntu Server instead, and install on top of that.

I installed Ubuntu Server just fine. I believe I followed the directions on the wiki correctly. When I got to the “supervisorctl reload” command, I got an error saying “<class ‘FileNotFoundError’>, [Errno 2] No such file or directory: file: /usr/lib/python3/dist-packages/supervisor/ line: 560”.

I ignored it for the moment and tried to do the “supervisorctl start mineos” command, but that returned “unix://var/run/supervisor.sock no such file”.

I don’t know linux very well, but looking at these errors, it looks like I don’t have Supervisor installed or something. If this is the issue, how do I get it? Otherwise, what is the problem?

Update: I figured out how to install supervisor and now mineos is running. Now my problem is that the webui is broken. None of the categories on the side have text, and the text at the top has code and brackets, and I am unable to really do anything. Here is a screenshot.

Update 2: I followed this tutorial and switched to Debian and now everything works.

Glad you got it working. Strange that you had so much trouble with Ubuntu, and Debian went through nice. I ran the Ubuntu SErver route, and run a ubuntu 20.04 server just fine.

It’s quite possible that the difference between the two installs (Ubu / Deb) is the version of NodeJS that was installed by the repository defaults.

It could be that one of them installed a version of NodeJS that didn’t build the npm modules correctly, causing the webui messy text. Unsure without closer investigation, but glad everything worked out!