Tried to download forge, but now the web ui is acting strange

So I tried to get Forge 1.12.2 and make a new server, but after that the profiles page says “No profiles are available; check internet connectivity and refresh the profile list.” and when I refresh sometimes not all servers show up. How can I fix this?

Try to refresh severs and profiles found in the drop-down in the upper right corner. If that doesn’t work, log out and back in. Finally, I would try to update the commit.

I can’t do anything with git because I have unmerged files? I never used it so I have no idea of what to do next. This is what I get back :

root@mineos games/minecraft# git fetch
root@mineos games/minecraft# git merge origin/master
error: merge is not possible because you have unmerged files.
hint: Fix them up in the work tree, and then use 'git add/rm <file>'
hint: as appropriate to mark resolution and make a commit, or use
hint: 'git commit -a'.
fatal: Exiting because of an unresolved conflict.
root@mineos games/minecraft#

If you have not deliberately and knowingly changed any files in that directory, then we can ignore those changes and ensure you have a recent commit with:

cd /usr/games/minecraft


cd /usr/games/minecraft
git reset --hard origin/master
[reboot the webui or the whole host]

I did that and it seems to work now. Thanks!