The web-UI is not doing anything

When I try to use the web-UI and press create server I do it but then the page refreshes and what I just made it gone this is what I get tho when doing

systemctl status mineos

● mineos.service - Start MineOS minecraft front-end
Loaded: loaded (/etc/systemd/system/mineos.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2023-08-29 22:07:40 UTC; 4min 10s ago
Process: 40820 ExecStart=/usr/bin/node service.js start (code=exited, status=0/SUCCESS)
Main PID: 40827 (mineos)
Tasks: 11 (limit: 4431)
Memory: 20.6M
CPU: 1.571s
CGroup: /system.slice/mineos.service
└─40827 mineos “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” “” >
Aug 29 22:07:39 spacesmp systemd[1]: Starting Start MineOS minecraft front-end…
Aug 29 22:07:39 spacesmp node[40820]: Starting mineos daemon…
Aug 29 22:07:40 spacesmp node[40820]: mineos daemon started. PID: 40827
Aug 29 22:07:40 spacesmp systemd[1]: Started Start MineOS minecraft front-end.

to note I do run pi-hole plex a nas on the same server would any of those cuz it plus the Profiles page tells me No Profiles Are Available; Check Internet Connectivity And Refresh The Profile List.

adding one thing it is a fresh install of ubuntu

Are you logging in as a root user or a non root user?
If your logging in as a root user that wont work
If your logging into a non root user then please try these options here

If you need to create a non root user do this
adduser mc
(Then go through the proccess of creating that user)
then to make sure your non-root user is functional and usable by the server do this
echo mc:passwordYouPut | chpasswd --crypt-method SHA512

I am logging in to a sudo user

create a non sudo aka non root user. Root users can use the profile feature. So reference above and make a non root user. if it doesnt work once again refer to

Now it is not letting me log in to the web-ui on any user
all I did was
adduser space
and tried to log in and it did not work so I tried darkness again and it does not work now

Is there a way I can give u a log for mineOS

Ok I just did a command and got this

root@spacesmp:~# npm install
npm WARN saveError ENOENT: no such file or directory, open ‘/root/package.json’
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN enoent ENOENT: no such file or directory, open ‘/root/package.json’
npm WARN root No description
npm WARN root No repository field.
npm WARN root No README data
npm WARN root No license field.

up to date in 0.43s
found 0 vulnerabilities

go ahead and do these commands

# cd /usr/games/minecraft
# git fetch
# git reset --hard origin/master
# git checkout master
# rm -rf ./node_modules
# npm install --unsafe-perm

The commands above basically nuke your webui and force reset factory reset. then do thise
npm install posix --unsafe-perm

After this it should work.

I've had your problem before and i just basically went down the whole line of commands top to bottom from the link.

Your root user should still work. But make a non root user aka your space user and

echo space:passwordYouPut | chpasswd --crypt-method SHA512

for some reason you need to run this to change the encryption password to sha512 otherwise you cant log in.
If your root user doesnt log in thats quite peculiar to me.

Just letting you know it is letting me make servers but it is still doing this in profiles

No Profiles Are Available; Check Internet Connectivity And Refresh The Profile List.

Wait I did sudo update and it is working now

Thank you so much jordan

You are welcome. I suffered from that too