Survival Skyblock Server Not Working

I’m not too sure which category this belongs to, but here’s the issue: I replace the world file with all the files in the (found here: and when I turn it on and join, I suffocate and die because the entire world is stone… btw the server I ran it on was 1.15.2.

Anyway, so I created a world, turned it on to get all the files generated, then turned it off, then went to filezilla and opened the world folder in the skyblock world, deleted everything and replaced it with everything in the file.

I turned it on and am greeted with this in the log:

Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498]
[11:45:53] ain/WARN]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[11:45:53] ain/WARN]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0]
[11:45:53] ain/WARN]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498]
[11:45:53] ain/WARN]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[11:45:53] [Server thread/INFO]: Starting minecraft server version 1.15.2
[11:45:53] [Server thread/INFO]: Loading properties
[11:45:53] [Server thread/INFO]: Default game type: SURVIVAL
[11:45:53] [Server thread/INFO]: Generating keypair
[11:45:53] [Server thread/INFO]: Starting Minecraft server on
[11:45:53] [Server thread/INFO]: Using epoll channel type
[11:45:53] [Server thread/INFO]: Preparing level “world”
[11:45:53] [Server thread/INFO]: [STDERR]: ./world/session.lock (Permission denied)
[11:45:53] [Server thread/INFO]: [STDERR]: at Method)
[11:45:53] [Server thread/INFO]: [STDERR]: at
[11:45:53] [Server thread/INFO]: [STDERR]: at
[11:45:53] [Server thread/INFO]: [STDERR]: at
[11:45:53] [Server thread/INFO]: [STDERR]: at crn.h(SourceFile:87)
[11:45:53] [Server thread/INFO]: [STDERR]: at crn.(SourceFile:51)
[11:45:53] [Server thread/INFO]: [STDERR]: at crp.a(SourceFile:113)
[11:45:53] [Server thread/INFO]: [STDERR]: at crp.a(SourceFile:109)
[11:45:53] [Server thread/INFO]: [STDERR]: at net.minecraft.server.MinecraftServer.a(SourceFile:360)
[11:45:53] [Server thread/INFO]: [STDERR]: at wd.d(SourceFile:219)
[11:45:53] [Server thread/INFO]: [STDERR]: at
[11:45:53] [Server thread/INFO]: [STDERR]: at
[11:45:53] [Server thread/ERROR]: Encountered an unexpected exception
java.lang.RuntimeException: Failed to check session lock, aborting
at crn.h(SourceFile:95) ~inecraft_server.1.15.2.jar:?]
at crn.(SourceFile:51) ~inecraft_server.1.15.2.jar:?]
at crp.a(SourceFile:113) ~inecraft_server.1.15.2.jar:?]
at crp.a(SourceFile:109) ~inecraft_server.1.15.2.jar:?]
at net.minecraft.server.MinecraftServer.a(SourceFile:360) ~inecraft_server.1.15.2.jar:?]
at wd.d(SourceFile:219) ~inecraft_server.1.15.2.jar:?]
at inecraft_server.1.15.2.jar:?]
at [?:1.8.0_232]
[11:45:53] [Server thread/ERROR]: This crash report has been saved to: /var/games/minecraft/servers/Skyblock_Gamer/./crash-reports/crash-2020-01-28_11.45.53-server.txt
[11:45:53] [Server thread/INFO]: Stopping server
[11:45:53] [Server thread/INFO]: Saving players
[11:45:53] [Server thread/INFO]: Saving worlds
[11:45:53] [Server thread/ERROR]: Exception stopping the server
java.lang.NullPointerException: null
at net.minecraft.server.MinecraftServer.a(SourceFile:559) ~inecraft_server.1.15.2.jar:?]
at net.minecraft.server.MinecraftServer.s(SourceFile:587) ~inecraft_server.1.15.2.jar:?]
at wd.s(SourceFile:597) ~inecraft_server.1.15.2.jar:?]
at inecraft_server.1.15.2.jar:?]
at [?:1.8.0_232]

I then looked online to see what the issue is and a lot of people said it was due to the session lock and recommended either deleting it entirely, or changing the permission to 777. I tried the 777, but not the deleting entirely.

When I did change it to 777, the logs were overflowed and couldn’t show until I refreshed (they were all gone when I refreshed too) but then when I join the server, the whole world is made of stone!

I’m not too sure what to do, please help!

I tried deleting the entire session lock file, did the exact same thing, server worked, but I just spawn in stone. Also the logs were too long.

Is the entire world stone?

Or, is where you spawn stone, and therefore it feels as if the entire world is stone.

Because if you’re simply spawning in an unlivable place in the world, the spawn point can be changed.

If your entire world is stone, then it’s probably not worth troubleshooting the lock file, because the world (the one copied to this specific minecraft server) is a throwaway, anyway.

Is there a reason to create the world if you’re just going to delete it? Does the skyblock download not come with all the necessary files, or does the installation steps explicitly tell you to generate a world and make these steps?

I only deleted the files in the world folder, so I can replace them with the ones in the Skyblock folder.
The entire world is stone, I dug up with my bare fists until around y=90.

Basically, I create the server and run it on Minecraft 1.15.2, then I stop the server, then I replace the files in the world folder with the ones in the Skyblock folder, turn on server, entire world is stone and overflowed logs…

I put the world file in my single player save folder and it completely works, so the problem isn’t with the skyblock world file. I have no idea why it won’t work.

The session lock file is a file that tell the OS that your server is allready runnung. occationally the session.lock file do not get deleted when your server stops (usually due to crashes and such). This will block your server from runnning uuntill the file is removed. Hence the adice to delete it.

When you replaced your world files, did you reset the player placement? Your server sets your players placement when it enters the world according to the UUID.dat or playername.dat file. If that file places your player according to old map files, and new map files do not match, your placement can end up underground (in stone). It could end up miles abouve ground as well, but seems you ended up underground.

Since this is a new server, try deleting the player files in your world driecotry

If you do not wish to do that, you can try to edit the player file to set a new location:

1 Like

I have 2 .dat files in my playerdata folder, I tried deleting both, and running server; didn’t work.
I tried deleting 1 and renaming the other to fit my UUID; didn’t work.

Then it sounds like the default spawn point is off. This is the command to move the default spawn point in a vanilla server:

Be aware that the default behaviour for spawn is this:

" If the server is not in adventure mode, players always spawn on the topmost block near ( x , z ) — y is effectively ignored. If the server is in adventure mode, then the new spawnpoint is exactly at the given coordinates, including the y coordinate (even if underground and even if there isn’t a block there) — if the y level given does not have space for the player then the spawnpoint moves up on the y axis until it does, at most y level 256."

Do this happend if you set up a new vanilla server? OR only after you copy in the world files?

Only in this case, I can make vanilla servers fine and I spawn normally. When I make the server I set the game mode to survival.