Support for ImagicalMine


#1

Now that PocketMine development seems to be stalled, can we get some support for other builds such as ImagicalMine? I’d like to be able to manage these from within my MineOS-Node implementation, but I am unable to make their builds work within MineOS. I have no problems running their builds standalone.


#2

What have you tried doing so far that didn’t work? This is my first time hearing of ImagicalMine…I don’t keep up much on new softwares much until somebody brings them to my attention.


#3

I run the Imagicalmine builds with now troubles. What errors are you getting?

I suspect it is a PHP-issue, the php-releases available through th MineOS profiles are to old.
-delete php downloadinfo- Sorry, to quick. jenkings.imagicalmine was slow today, wrong link.

-edit again: Found a working link for downloading php-packages:
https://bintray.com/package/files/pocketmine/PocketMine/Unix-PHP-Binaries


#4

Yes, I suspect some of my issues are PHP related. However now that they have indicated they will not be supporting PHP5 for future builds, PHP7 will need to work. I still haven’t figured out how to get a PHP7 build working. I’m not a developer, so sites like github and such where these are posted are not much help to me.

What I have been able to do thus far is get their PHP5 based build to work apart from MineOS. Since launching ImagicalMine requires ./start.sh, how would i set up MineOS to run this? I have the server folder under /var/games/minecraft/servers/ and in there I have the php binaries along with the phar file but trying to launch that from MineOS fails. I’m sure it is probably something in my setup of the folder, I’m just not sure where to look.


#5

OK, so call me silly, for whatever reason I couldn’t make it work, but now I can. I’m not sure if it was a permissions problem or a versioning problem with the phar file, but I’ve managed to get the PHP5 version server to start in MineOS. Yay!

So two things:

  1. Has anyone got a PHP7 build working and how did you do that?

  2. Is there any way to add ImagicalMine as a profile download source and how could I do that?

Thanks.


#6

Seems to be the case, yes. The PHP binaries you see listed in the webui are the ones that match the main Pocketmine URL, though, which they seem not to have updated:


#7

I just made some commits just now that should update PHP binaries so that the more recent 5.6 and 7.x appear.

However, it does not appear that any of the 7.x binaries work–this is not related to MineOS, but instead they are simply bundling and distributing a broken package.

Because one day it’s expected to work, I’ve left it in the webui, available under ‘snapshot’. When the binaries themselves are fixed, it should be as simple as re-downloading them.

I’ve also added imagicalmine to the profile list; I can confirm it executes properly when using PHP5.6.


#8

Thanks very much for this! I updated MineOS and the new profiles were there. So I created a new test server to try it out and here’s what I saw:

From the Server At A Glance screen:
I copied the PHP binaries profile to the server folder
I copied the ImagicalMine phar file to the server folder
I selected the ImagicalMine.phar file as the runnable jar
I started the server.

The server files started to generate and a server.log was created and started to display but the Start button never lightened and any repeated pressing of the start button did nothing. Stop also did nothing. I had to execute a full stop and start of MineOS with supervisorctl at which point I could then start the server and all appeared to be running normally. When I attempt to stop the server, it appears to stop but hangs and eventually crashes. This also happens outside of MineOS so maybe a problem with my setup. I am running MineOS installed on Ubuntu 15.10. The crash error I see in Ubuntu is “php crashed with SIGSEGV in zend_std_object_get_class()”, if that helps.

If there is anything I can help you with in the way of logs, etc. I’m happy to do it. Just let me know what you need.


#9

And an added plus…I LOVE the Player Interaction tab that shows up under Logging. Very handy. Wish that showed up for standard servers.


#10

It does, if query-enable is true for that server (and the minecraft server software supports it)


#11

Well, I tried that, too, and lo and behold, it works great! I’ve been using MineOS for the better part of the past year and I never knew that feature was there. One more reason to keep using this fine product. Thanks very much.

I’m still trying to figure out some of the quirks with starting and stopping ImagicalMine. Probably in their code but it is nice to have it running for now.