/stop timing out

I am seeing this in the mineos.log file

{"level":"error","message":"Ping, MC Server not available on port 25565","timestamp":"2022-09-23T01:16:17.518Z"}
{"level":"error","message":"Ping, MC Server not available on port 25565","timestamp":"2022-09-23T01:16:22.521Z"}
{"command":"stop","uuid":"46c28510-3add-11ed-ae1f-73ae6aed1d9a","time_initiated":1663895756769,"success":false,"err":true,"time_resolved":1663895787052,"level":"error","message":"[test_server] command \"stop\" errored out:","timestamp":"2022-09-23T01:16:27.052Z"}
{"level":"error","message":"Ping, MC Server not available on port 25565","timestamp":"2022-09-23T01:16:27.524Z"}
{"level":"error","message":"Ping, MC Server not available on port 25565","timestamp":"2022-09-23T01:16:32.525Z"}
{"level":"error","message":"Ping, MC Server not available on port 25565","timestamp":"2022-09-23T01:16:37.527Z"

The server is functional when I start it, and stopping the server works (connected users are disconnected and can’t reconnect, mc server logs stop showing anything)

Though on MineOS it throws up an error that /stop failed and the server is still shown as online even though it is offline.

Only restarting MineOS does it resolve (shows the server as offline), but this seems very kludgy as a solution

The server logs don’t show anything beyond the following when sending the /stop command

[18:15:56] [Server thread/INFO]: Stopping the server
[18:15:56] [Server thread/INFO]: Stopping server
[18:15:56] [Server thread/INFO]: Saving players
[18:15:56] [Server thread/INFO]: Saving worlds
[18:15:57] [Server thread/INFO]: Saving chunks for level 'ServerLevel[world]'/minecraft:overworld

Any details you can give?
Game version,
MineOS commit version,
Are you running the TKL distro or a self install on another distro?
Hardware specs?

Also I would have thought a refresh of the browswr page rather than restarting mineos would show the correct info (unless that is what you meant)

MineOS commit: b6e0d1e
Minecraft Version: Mojang, 1.19.2
Running as a docker container on Unraid
Hardware: Ryzen 5900x, 32GB Ram (Assigned 6GB to server, also tried 8GB)

Refreshing (Including a hard refresh) doesn’t update the page. Only a restart seems to work

Quick update

I installed a different docker container for MineOS from a different author that works as expected, I’ll have to speak with the author of the container I had issues with regarding the behavior problems

Cool. Glad it worked.
I couldn’t think of a reason why it wouldn’t work as expected.
The commit was old, not sure how old, but that probably wouldn’t be the issue as I don’t think anything around stop has changed in a long time.