Some Help Please - webUI doesn't work

So I recently asked a friend to install MineOS on a server box they maintain for games, they said yes, yadda yadda.

Now, the bare bones of things are functional - which is great! - and I can SSH in and start the server and play, and my other players can get in play. All that’s fantastic.

But for some reason, the webUI isn’t functional. I can’t get it to make a new server, import an old server, or anything like that, which means my only method of stopping the server is rebooting the underlying OS - not great. Further, my only option to start it after a server boot is to SSH in - I’m OK with Linux, I can manage that, but it’s still not great either.

So to be clear, you can get into the webui, but none of the functionality works?

Can you share the system logs for MineOS at /var/log/mineos.log?

@hexparrot Your clarification is correct. As far as logs, hopefully I’ll be able to edit this post with them momentarily.

Edit: Alright! I got the log. And for some reason now the webUI can start, stop, and backup ONE existing server but none of the other attempts (including making the imported one from Aeternos work). See here for the log:

The logs are filled with errors like these:

"increments":[{"step":"0B","time":"Fri Oct 11 13:23:42 2019","size":"520 MB","cum":"520 MB"},{"step":"1B","time":"Fri Oct 11 09:43:35 2019","size":"124 KB","cum":"520 MB"},{"step":"2B","time":"Fri Oct 11 09:42:43 2019","size":"104 bytes","cum":"520 MB"}],
"message":"[Hereticus] Error with get_page_data { Error: ENOENT: no such file or directory, lstat '/var/games/minecraft/backup/Hereticus/rdiff-backup-data/'\n  errno: -2,\n  code: 'ENOENT',\n  syscall: 'lstat',\n  path: '/var/games/minecraft/backup/Hereticus/rdiff-backup-data/' }",

This suggests to me that somehow an errant missing file is stopping the webui from polling the servers properly during the get_page_data function of the webui.

It calls out the file specifically, an artifact from rdiff-backup:


It’s uncertain what caused the problem to start, but it seems to be a backup issue revolving around Hereticus.

Possible way to handle this:

  1. make an archive of hereticus.
  2. delete the hereticus RESTORE points, all of em
  3. make a new restore point

This is probably my favored solution. First, you’re protected because the LIVE files aren’t touched. Second you have archives up. Restore points are a dime a dozen. Once all the existing restore points are gone, it’ll probably have no issue starting new restore points at whatever interval you’ve chosen.

Since you’re not able to depend on the webui, it’d go like this, from the terminal session:

[log in as mc]

cd /usr/games/minecraft
./mineos_console.js -s Hereticus archive
rm -rf /var/games/minecraft/backup/Hereticus/*

[go back in the webui, and it’ll likely work, completely.]

I followed your steps, and saw no changes - then I just tried to delete Hereticus (this is fine, it’s not important), and saw that it actually deleted (which is fine). Don’t yet seem to be able to start the other worlds - will try after server reboot when folks aren’t actively bugging me to play. And thanks for your help so far. :slight_smile: