[SOLVED] We cant see our servers in dashboard

Hi guys,
we have big problem with MineOS. If I login into the MineOS, dashboard never show our servers (screenshot: http://prntscr.com/5ldyrz ; note: There shoul be ten servers). I tried restart server via command “shutdown -r now” five times, but without results. This bug start from yesterday. It’s looks like system can’t find servers on FTP. I think it.

Thank you for your replies & help



Ok i solved it. We cannot use symbols like “_” “-” or dots or comma in names of servers. I renamed servers to only letter and everything works.

Thanks so much! I really appreciate it!

For the technical reason behind this is because the server name must be discernible from the screen name it creates.

So, server test would be mc-test and is invoked with screen -dmS mc-test.

If there are any additional, unsupported characters, the screen binary will error out. In addition, the server name must be a valid file name in Linux, which can be from the following set:


MineOS imposes the following restrictions:

valid_chars = set('%s%s_.' % (ascii_letters, digits))

Or in other words, everything above except hyphen, just to make the screen names cleaner for parsing, e.g., mc-my-awesome-server.