[SOLVED] Updated, server listed, start button does nothing

Using AWS Linux (Ubuntu 18.04.5 LTS). Node v10.23.0 (tried also with 4 and 8). Npm v6.14.8. Java 11 (OpenJDK 64-Bit Server VM 11.0.9+11-Ubuntu-0ubuntu1.18.04.1)

I’ve been running on this same hardware for years, but recently had to rearrange my drive paths. I thought I should update the webui, since I hadn’t for a long time. Now, since I have done so, I have gotten an error (which I fixed), and now trying to start the server does nothing.

This setup worked perfectly prior to my updating the webui.

I have tried starting the jar file directly with java, and that works just fine!

I also am not using the /var/games/minecraft folder at all. My data lives in /data/host/games/minecraft. I have set that whole folder and subfolders as owned by mc:mc.

The error I got was about not finding the userid/build/Debug path. I edited the loader manually and removed the reference to Debug and replaced it with Release.

As stated above, clicking start does nothing, not even show the popup I used to see saying that the server was being started. Nothing appears in the latest.log file for the server. The mineos.log file simply states that the start command was received, then nothing.

Ideas? I’ve removed MineOS and reinstalled it from scratch many times (and changed my conf file as shown below). I have not removed my servers, but I have created a test one using 1.12, but it won’t run either.

Here is my mineos.log:
{“level”:“info”,“message”:"[Koohiisan] Discovered server",“timestamp”:“2020-11-10T17:56:20.766Z”}
{“level”:“info”,“message”:"[Koohiisan] Created tail on logs/latest.log",“timestamp”:“2020-11-10T17:56:20.768Z”}
{“level”:“error”,“message”:"[Koohiisan] Create tail on server.log failed",“timestamp”:“2020-11-10T17:56:20.769Z”}
{“level”:“info”,“message”:"[Koohiisan] Watching for file generation: server.log",“timestamp”:“2020-11-10T17:56:20.769Z”}
{“level”:“error”,“message”:"[Koohiisan] Create tail on proxy.log.0 failed",“timestamp”:“2020-11-10T17:56:20.779Z”}
{“level”:“info”,“message”:"[Koohiisan] Watching for file generation: proxy.log.0",“timestamp”:“2020-11-10T17:56:20.779Z”}
{“level”:“error”,“message”:"[Koohiisan] Create tail on logs/fml-server-latest.log failed",“timestamp”:“2020-11-10T17:56:20.780Z”}
{“level”:“info”,“message”:"[Koohiisan] Watching for file generation: logs/fml-server-latest.log",“timestamp”:“2020-11-10T17:56:20.780Z”}
{“level”:“info”,“message”:"[Koohiisan] Using skipDirEntryPatterns: backups,cache,cr_world,crash-reports,debug,players,plugins,world,world_nether,world_the_end,dynmap,web,region,playerdata,stats,data",“timestamp$
{“level”:“info”,“message”:”[test] Discovered server",“timestamp”:“2020-11-10T17:56:20.808Z”}
{“level”:“error”,“message”:"[test] Create tail on logs/latest.log failed",“timestamp”:“2020-11-10T17:56:20.808Z”}
{“level”:“info”,“message”:"[test] Watching for file generation: logs/latest.log",“timestamp”:“2020-11-10T17:56:20.808Z”}
{“level”:“error”,“message”:"[test] Create tail on server.log failed",“timestamp”:“2020-11-10T17:56:20.808Z”}
{“level”:“info”,“message”:"[test] Watching for file generation: server.log",“timestamp”:“2020-11-10T17:56:20.809Z”}
{“level”:“error”,“message”:"[test] Create tail on proxy.log.0 failed",“timestamp”:“2020-11-10T17:56:20.809Z”}
{“level”:“info”,“message”:"[test] Watching for file generation: proxy.log.0",“timestamp”:“2020-11-10T17:56:20.809Z”}
{“level”:“error”,“message”:"[test] Create tail on logs/fml-server-latest.log failed",“timestamp”:“2020-11-10T17:56:20.809Z”}
{“level”:“info”,“message”:"[test] Watching for file generation: logs/fml-server-latest.log",“timestamp”:“2020-11-10T17:56:20.809Z”}
{“level”:“info”,“message”:"[test] Using skipDirEntryPatterns: world,world_the_end,world_nether,dynmap,plugins,web,region,playerdata,stats,data",“timestamp”:“2020-11-10T17:56:20.809Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 2cd410a Fix ERR_OUT_OF_RANGE during Buffer.write() (#373)\n”,“timestamp”:“2020-11-10T17:56:20.912Z”}
{“level”:“info”,“message”:"[WEBUI] New file found in import directory /data/host/games/minecraft/import/server-koohiisan_2019-05-21_00:39:23.tgz",“timestamp”:“2020-11-10T17:56:21.113Z”}
{“level”:“info”,“message”:"[Koohiisan] eula.txt detected: ACCEPTED (eula=true)",“timestamp”:“2020-11-10T17:56:21.354Z”}
{“level”:“info”,“message”:"[Koohiisan] autostart = true",“timestamp”:“2020-11-10T17:56:25.865Z”}
{“level”:“info”,“message”:"[Koohiisan] Server started. Waiting 10000 ms…",“timestamp”:“2020-11-10T17:56:26.044Z”}
{“level”:“info”,“message”:"[WEBUI] mc connected from",“timestamp”:“2020-11-10T17:56:30.660Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Mojang Official Minecraft Jars (488 entries)”,“timestamp”:“2020-11-10T17:56:31.056Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Feed the Beast Server Packs (566 entries)”,“timestamp”:“2020-11-10T17:56:31.876Z”}
{“level”:“info”,“message”:"[Koohiisan] mc ( joined server namespace",“timestamp”:“2020-11-10T17:56:32.017Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Feed the Beast Third-Party Server Packs (278 entries)”,“timestamp”:“2020-11-10T17:56:32.091Z”}
{“level”:“info”,“message”:"[test] mc ( joined server namespace",“timestamp”:“2020-11-10T17:56:32.091Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Spigot (1 entries)”,“timestamp”:“2020-11-10T17:56:32.109Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Forge Mod (47 entries)”,“timestamp”:“2020-11-10T17:56:32.110Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Imagicalmine (1 entries)”,“timestamp”:“2020-11-10T17:56:32.116Z”}
{“level”:“info”,“message”:"[Koohiisan] transmittting existing file contents: logs/latest.log (33701 bytes)",“timestamp”:“2020-11-10T17:56:32.877Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Mianite (23 entries)”,“timestamp”:“2020-11-10T17:56:32.878Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Paper (23 entries)”,“timestamp”:“2020-11-10T17:56:32.919Z”}
{“level”:“info”,“message”:“Downloaded information for collection: BungeeCord (10 entries)”,“timestamp”:“2020-11-10T17:56:33.022Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Nukkit (2 entries)”,“timestamp”:“2020-11-10T17:56:33.023Z”}
{“level”:“info”,“message”:“Downloaded information for collection: SpongeVanilla (0 entries)”,“timestamp”:“2020-11-10T17:56:33.122Z”}
{“level”:“info”,“message”:“Downloaded information for collection: Cuberite C++ Server (4 entries)”,“timestamp”:“2020-11-10T17:56:33.590Z”}
{“level”:“info”,“message”:"[test] autostart = false",“timestamp”:“2020-11-10T17:56:36.045Z”}
{“level”:“error”,“message”:"[test] Aborted server startup; condition not met: true",“timestamp”:“2020-11-10T17:56:36.045Z”}
{“level”:“info”,“message”:"[Koohiisan] issued command : “start”",“timestamp”:“2020-11-10T17:56:43.603Z”}
{“level”:“info”,“message”:"[Koohiisan] received request “start”",“timestamp”:“2020-11-10T17:56:43.604Z”}

Here is my mineos.conf (from /etc and same from /usr/games/minecraft):
use_https = true
socket_host = ‘’
socket_port = 8440
base_directory = ‘/data/host/games/minecraft’

ssl_private_key = ‘/etc/ssl/certs/mineos.key’
ssl_certificate = ‘/etc/ssl/certs/mineos.crt’
ssl_cert_chain = ‘’

webui_locale = ‘en_US’
additional_logfiles = ‘’
optional_columns = ‘’

Here is my docker-compose.yml file (not sure if this matters):
version: ‘3’

image: hexparrot/mineos:latest
container_name: mineos_server
- mineos
restart: unless-stopped

# Adjust as needed; if this is too short, stopping the container
#  may corrupt map data
stop_grace_period: 10m

  # Using a bind mapping is preferrable here due to how docker
  # stores names volumes by default in /var/lib/docker/volumes
  # with permissions that prevent normal users from accessing
  # the folder structure.
  - /var/games/mineos/minecraft:/data/host/games/minecraft

  # Should the web interface use HTTPS or HTTP?
  # Valid entries are "true" and "false" (without quotes)
  USE_HTTPS: "true"

  # What port should the web interface listen on?
  # This is independant of the USE_HTTPS setting.

  # On startup, mineos will check if an account of this name exists.
  # If it does not exist, one will be created. This account, and
  # any other created with this variable will be permitted to login
  # to the web interface.

  # If the account listed above does not already exist, when mineos
  # creates it, it will do so with UID. If an account with this UID
  # already exists, account creation will be aborted.
  USER_UID: 1000

  # If the account is being created, it will use either the password
  # set below, or a random, 20 character password will generated for
  # you and displayed in the console log. After first launch, you
  # should check the log.
  USER_PASSWORD: random_see_log

  # HTTPS port for web interface. If you change the SERVER_PORT
  # variable, also change this mapping.
  - "8443:8443/tcp"

  # Minecraft server ports. 25565 is the default, but is you plan
  # on running multiple servers at the same time, each will need
  # a unique port unless you are using bungiecord.
  # Expand this range as needed.
  - "25565-25570:25565-25570/tcp"
  - "25565-25570:25565-25570/udp"



Well, I think I reset the permissions somewhere along the lines on my data directory, and I really shouldn’t have. I think.

I did a chmod +x /data/host/games/minecraft/ -R and it starts and stops now.

Latest.log isn’t updating, but that’s likely a perms issue too.