[Solved] Unable to access the MineOS Web UI on clean install

So I installed Ubuntu Server 14.04 LTS twice, the first time I executed the commands manually because I wanted something alittle more custom, like using Java 8 instead of OpenJDK7 for example. When I tried accessing the WebUI at https port 8443 I got the “ERR_CONNECTION_REFUSED” error and tried a couple things to try to fix it which never fixed it so I removed everything and did a second clean install, however this time I used the wget friendly script and installed nothing else. Then I tried accessing the UI once again with no luck so I rebooted and tried, still with no luck. I tried setting up iptables which was something I did back when I used to experiment with the pre-configured image months back (the last time I really messed with it was months ago) and I still get the “ERR_CONNECTION_REFUSED” error. I remember that error from the pre-config image which is when I stop the UI so I checked to see whether or not the UI runs or not and it does appear to be running, and on system startup you can see it shows “Starting MineOS Servers” and “Starting mineos” as well so that can’t be it. Another thing is that when typing “start mineos” or “stop mineos” it returns “Unknown job”.

IPtables config (–list):

root@TestSys02:~# iptables --list
Chain INPUT (policy DROP)
target     prot opt source               destination         
ACCEPT     all  --  anywhere             anywhere             ctstate RELATED,ESTABLISHED
ACCEPT     all  --  anywhere             anywhere            
DROP       all  --  anywhere             anywhere             ctstate INVALID
UDP        udp  --  anywhere             anywhere             ctstate NEW
TCP        tcp  --  anywhere             anywhere             tcp flags:FIN,SYN,RST,ACK/SYN ctstate NEW
ICMP       icmp --  anywhere             anywhere             ctstate NEW
REJECT     udp  --  anywhere             anywhere             reject-with icmp-port-unreachable
REJECT     tcp  --  anywhere             anywhere             reject-with tcp-reset
REJECT     all  --  anywhere             anywhere             reject-with icmp-proto-unreachable
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:8443
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:25565
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:http-alt

Chain FORWARD (policy DROP)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain ICMP (1 references)
target     prot opt source               destination         

Chain TCP (1 references)
target     prot opt source               destination         
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:ssh

Chain UDP (1 references)
target     prot opt source               destination     

IPtables config (-S):

root@TestSys02:~# iptables -S
-A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m conntrack --ctstate INVALID -j DROP
-A INPUT -p udp -m conntrack --ctstate NEW -j UDP
-A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m conntrack --ctstate NEW -j TCP
-A INPUT -p icmp -m conntrack --ctstate NEW -j ICMP
-A INPUT -p udp -j REJECT --reject-with icmp-port-unreachable
-A INPUT -p tcp -j REJECT --reject-with tcp-reset
-A INPUT -j REJECT --reject-with icmp-proto-unreachable
-A INPUT -p tcp -m tcp --dport 8443 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 25565 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 8080 -j ACCEPT
-A TCP -p tcp -m tcp --dport 22 -j ACCEPT

And the last part of the MineOS log from /var/log/mineos.log

[14/Nov/2015:23:23:52] ENGINE Bus STARTING
[14/Nov/2015:23:23:52] ENGINE Forking once.
[14/Nov/2015:23:23:52] ENGINE Forking twice.
[14/Nov/2015:23:23:52] ENGINE Daemonized to PID: 952
[14/Nov/2015:23:23:52] ENGINE PID 952 written to '/var/run/mineos.pid'.
[14/Nov/2015:23:23:52] ENGINE Started monitor thread '_TimeoutMonitor'.
[14/Nov/2015:23:23:52] ENGINE Started monitor thread 'Monitor'.
[14/Nov/2015:23:23:52] ENGINE Started monitor thread 'Autoreloader'.
[14/Nov/2015:23:23:53] ENGINE Serving on
[14/Nov/2015:23:23:53] ENGINE Bus STARTED

One thing I did notice was that for some reason it appears to be starting on port 8080 (according to the logs) so I tried https port 8080 which didn’t work either.

Now I’m stuck.

When installing Ubuntu Server, OpenSSH and Mail Server options were selected, and under Mail System configuration (on the screen after) was set to Local Only and Mail Server Name left as default “localhost”. I am also installing this within a VM via VirtualBox using default settings (768M RAM, 8G HDD) and from Ubuntu Server install, HDD partitioning setting is “Use Whole Disk” (without LVM) and the default partition layout that appears after.

You git cloned hexparrot/mineos, not hexparrot/mineos-node. Perhaps you followed the Python based webui instructions instead?

I followed instructions from the node.js links (it’s above the python links in navigation) the first time, but the second time I used the convenience installer script from within the same page.

Set of instructions used (pulled from browser history): MineOS-node (apt-get) - MineOS

I’ll create another VM and try it again when I get the chance.

So I did a 3rd install but this time I copied the wget link without actually browsing to it, then ran the script. However towards the end it gave ERR with the kernel version and such, and then I tried browsing to the UI which again didn’t work so I rebooted, still with no luck. However, I did fix it in the end by resetting the scripts using the instructions from Updating the Webui - MineOS. After that completed, I tried browsing to it, tested it, and it works as it should. What I’ll be doing now is installing a few Ubuntu Server VMs, and then installing MineOS node as well as a few other programs to see how well it performs, and whether each install will need me to reset the ui after the scripts complete. I was thinking of creating different distros on VirtualBox images each with MineOS node then later on with different sets of programs, that is, if I have your permission to include the UI within those images. If not I could simply create a script that’d do it at a later time. But good work as usual :smile:

1 Like