[SOLVED] Ubuntu 14.04 with MineOS hangs on reboot/shutdown

When I reboot or shutdown the machine, it hangs on the screen shown below. I’ve tried a few things, such as editing the grub file, with no luck. Thanks for your help!
http://imgur.com/BEkyoft

Try shutting down with shutdown -v -h now.

What does your /var/log/kern.log say when you get the server back up again? It should let us know where the halting is occurring.

That said, since MineOS is the last service opened, can you verify that the webui can be started and stopped manually (as shown in the wiki)?

I’m actually having this exact same problem!
I don’t mean to highjack the thread, but I’m willing to provide my logs in the name of help.

I notice that at idle, with absolutely NO MC servers running (none have run since last restart) mineos is using 197048KiB of RSS and a whopping 1353332KiB of VSZ.

The problem seems to not be a matter of overall uptime because my system has been up for less than 5 minutes and mineos is up to those sizes within the first few minutes. Note my system is almost always on because it functions also as a small personal NAS.

I do not see anything at all related to “minecraft” “mineos” “java” or “webui” in /var/log/kern.log
I also don’t seem to see anything from the shutdown squence in the kern.log from my shutdown using the -v arg. The log jumps from about 45 minutes ago until when the OS started booting up again.

Dec 23 19:45:28 serv kernel: [ 35.902095] type=1400 audit(1450917928.774:67): apparmor=“STATUS” operation=“profile_replace” profile=“unconfined” name="/usr/sbin/cupsd" pid=2686 c$
~Shutdown -v was initiated around about 20:25, it took a full 5 minutes to shutdown fully~
Dec 23 20:31:47 serv kernel: [ 0.000000] Initializing cgroup subsys cpuset
Dec 23 20:31:47 serv kernel: [ 0.000000] Initializing cgroup subsys cpu
Dec 23 20:31:47 serv kernel: [ 0.000000] Initializing cgroup subsys cpuacct
Dec 23 20:31:47 serv kernel: [ 0.000000] Linux version 3.13.0-74-generic (buildd@lcy01-07) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #118-Ubuntu SMP Thu Dec 17 22:52:10 UTC $
Dec 23 20:31:47 serv kernel: [ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-74-generic root=UUID=a4566c56-6b57-4168-9bf8-8e41c5edbd22 ro quiet splash vt.handoff=7

$ stop mineos results in a permissions error as follows:

stop: Rejected send message, 1 matched rules; type=“method_call”, sender=":1.65" (uid=1000 pid=2881 comm=“stop mineos “) interface=“com.ubuntu.Upstart0_6.Job” member=“Stop” error name=”(unset)” requested_reply=“0” destination=“com.ubuntu.Upstart” (uid=0 pid=1 comm="/sbin/init")

$ sudo stop mineos seems to take forever and never completes (within the 5 minutes i allowed it)

Just some info about my host:
Intel Core 2 Duo.
4GB RAM
NVIDIA 8300GS
Ubuntu 14.04 LTS, 64-bit, all updates available as of today installed.

Any help you can provide would be appreciated and I look forward to helping in any way I can.
Thanks in advance!

EDIT: In fairness, I’m not sure this problem is linked directly to MineOS. Even when stopping mineos from command line (see below) before issuing a reboot, it still hangs. Perhaps it’s a dependency having issues. Node, perhaps?
I should also note i’m entirely unable to stop or start mineos with “sudo start/stop mineos”, but if i do as gdgeorge suggested in another post, i can start and stop, respectively.

$ cd /usr/games/mineos
$ sudo node service.js start/stop

sumbrawd, are you by any chance running NVIDIA graphics?

Here is the log: http://pastebin.com/EqZZkyvb

When I run mineos stop it freezes on that command. While frozen, the web-ui is still completely functional.

I can however start stop with the command jake5253 provided.

It seems like the mineos service isn’t stopping when being told to do so.

No, I am using a Radeon HD 5450.

Here are my system specs:
Asus x99 deluxe
Xeon E5-2683 V3
Radeon HD 5450
Kingston 120GB SSD

Any word on the issue? I’ve completely reinstalled since posting this, and I still am experiencing hanging shutdowns. I can confirm that before mineos was installed, the shutdown process did not hang at all.

I have exactly the same problems :confused:

I’ve looked into this a bit, but haven’t discovered a solution… Worse, neither upstart nor node seems to have a way to appropriately log this or get more verbose error messaging.

One bright side is that this seems to be localized to upstart specifically, which is Ubuntu only–and not the only option available for managing daemon processes. So instead you might just uninstall the upstart script and instead use the supervisord scripts for launching and managing the process.

rm /etc/init/mineos.conf
apt-get install supervisor
cp /usr/games/minecraft/init/supervisor_conf /etc/supervisor/conf.d/mineos.conf
supervisorctl reload

Since the issue is that you can’t reboot and shutdown, it’d be preferable that you instead killall mineos first, so revised instructions might look like this:

killall mineos
rm /etc/init/mineos.conf
apt-get install supervisor
cp /usr/games/minecraft/init/supervisor_conf /etc/supervisor/conf.d/mineos.conf
reboot

I can confirm that supervisord has no problem stopping the mineos process…no idea why upstart fails.

1 Like

Thank you for the solution.