[SOLVED] Trouble Updating

So I have installed MineOS on my Ubuntu server but for some reason the webui doesn’t look the same as when I installed the MineOS iso. I have followed the pages on how to update but it still looks the same to me. Any help will be appreciated.

Try resetting the scripts using the instructions on the MineOS wiki

If you run in to any trouble, please provide a copy/paste of the commands you entered and the output it displayed.

@hexparrot

    root@brandonsserver:~# cd /usr/games/minecraft
    root@brandonsserver:/usr/games/minecraft# git fetch
    root@brandonsserver:/usr/games/minecraft# git reset --hard origin/master
    HEAD is now at ce19bf4 Merge pull request #155 from glasspelican/master
    root@brandonsserver:/usr/games/minecraft# rm -rf node_modules
    root@brandonsserver:/usr/games/minecraft# npm install
    npm WARN enoent ENOENT: no such file or directory, open '/usr/games/minecraft/package.json'
    npm WARN minecraft No description
    npm WARN minecraft No repository field.
    npm WARN minecraft No README data
    npm WARN minecraft No license field.
    root@brandonsserver:/usr/games/minecraft# chmod +x mineos_console.js
    chmod: cannot access 'mineos_console.js': No such file or directory
    root@brandonsserver:/usr/games/minecraft#

What is the current version of webui?

glasspelican”?


At first when I originally saw/read this I was like “hm, maybe the python version was installed instead of node or maybe vice versa by accident” but clearly it’s more than that; at this point I’d recommend just reinstalling or starting over from scratch, whichever suits you using the installation instructions on the MineOS wiki. If you chose to reinstall I’d suggest you to first ‘rm -rf /usr/games/minecraft’ followed by those instructions.

1 Like

Thank you @JayMontana36 it worked.

glasspelican refers to a pull that did, in fact, come from the python webui repo so you were right on.

1 Like