[SOLVED]Spigot not starting in WebUi

I recently changed the OS of my personal host computer to MineOS, and am having a problem getting spigot to run. Whenever I go to start the server from the WebUI, I get a notification saying that is started successfully, but it did not actually start. There is nothing in the console, and no response from the Offline/Online light. The WebUI is up to date with version ef3b205. I obtained the jar from the builder on the spigotmc website and am sure it is working. I can use SSH to start the server from the host, not through the UI, and will work perfectly. The WebUI console will also show the output from the server not running in it, but will not respond to a sent command from the UI. I am decently new to linux, so I hope I am not looking over anything.
Thanks in advance!

When you used SSH to start the server from the command line, did you do it as root?

9/10 times things work from the CLI and don’t work from the web-ui, this is the cause–because now the files are root owned, and the web-ui runs the servers as unprivileged users.

If this is the case, the solution is likely: chown -R mc:mc /var/games/minecraft/servers/yourservername, where mc:mc is the user:group and substituted yourservername.

I was able to run it from both accounts, but at first root

Ran the command and still no change. I checked the server folder using the turnkey file manager, and it is now owned by mc, but still not able to start it from the ui.
Thanks for the quick reply!
EDIT: Now when I press the start button, it says “server did not respond to the request”
EDIT 2: Performed a restart, and is back to the original “Start[success]”

Hey @hexparrot, is there any way to log the output from the console from trying to run in the ui? Might be able to identify the problem from there.

Exact same problem here.

Downgraded from CenOS7 to 6 and problem went away

Did you install over an already existing OS? I seem to have Debian :confused:
Will try upgrading and downgrading and see if this changes anything.

I installed it on top of centos 7, went to centos6 and both my servers work fine.

The web-ui simply reads the file contents of the Minecraft log itself, which also means it does not include user input. You can see this in server.log, or in newer server jars /logs/latest.log.

If you would like to interact with the server directly, connect to its screen instance:

Thanks, but still no luck. Any other suggestions?

No luck reading the log?

No, it seems like it doesn’t start at all. Nothing generates when started, such eula.txt or the world.

Is there a profile created and assigned to this server?

Is the profile “updated” so there’s a checkmark indicating the jar has been downloaded?

Yes, and it is updated. Could a problem be created from the jar being created in windows (due to the DMCA takedown, I had to compile the jar myself using a compiler jar) and uploaded to a cloud storage website? I uploaded my jar to dropbox, and pasted the share link in the url.

What are your profile settings? I need to reproduce what you’re doing and then see what might be going awry

These are settings I have been trying to use

Profile Name: spigot-1.8
Type: Standalone runnable jar
download URL: https://www.dropbox.com/s/83aouflmbwo6iqv/spigot.jar?dl=0 (feel free to use this link to reproduce problem)
save download as spigot.jar
jarfile to run: spigot.jar
java arguments: nogui

Then I click Download Now and it gives the Ok checkmark.

The jar it is downloading (if you check the files themselves) is only a few KB large. The URL you provided is the landing page for the download, rather than the download, and the web-ui wouldn’t know that it should instead download the file behind the download button.

Thus, while you’re getting a file called spigot.jar, it’s really the html file of the page that loads when you click your provided URL.

I recommend that you just get the jar and place it manually on the server.

Remove this existing profile, create a new one with the settings:

Profile Name: spigot-1.8
Type: Standalone runnable jar
download URL: notused
save download as spigot.jar
jarfile to run: spigot.jar
java arguments: nogui

Then, manually place via SFTP the spigot.jar file in /var/games/minecraft/profiles/spigot-1.8/

Cannot Create remote file
Permission denied.
Error code: 3
Error message from server: Permission denied

I logged in with the mc account, will see if it can be done with root account and then change the ownership.

Success! Used Webmin to put the jar in the folder and it worked! Thank you for your help. Great work on MineOS by the way…

For profiles, they’re supposed to be owned by root.