[SOLVED] Spigot/CraftBukkit Fatal: $Home not set

Hi everyone,

I have just installed the MineOS Jessie from the website and I followed the install and instructions but I receive the fatal: $Home not set error after hitting the Build Spigot button on the Spigot/CraftBukkit screen. I have tried every version on the page but the error is the same. I read the post here Spigot Autobuild and I checked the commit version which is 0e45be7 I checked the files in post and they have all the proper code in them user=root, etc.

Here is the whole error

Loading BuildTools version: git-BuildTools-5861ac0-46 (#46)
Git name not set, setting it to default value.
Exception in thread “main”
fatal: $HOME not set
java.lang.RuntimeException: Error running command, return status !=0: [git, config, --global, user.name, BuildTools] at org.spigotmc.builder.Builder.runProcess(Builder.java:535) at org.spigotmc.builder.Builder.main(Builder.java:154) fatal: $HOME not set

I am at my wits ends since I’m not a Linux expert.

Thanks,

-Doug

My apologies. The Jessie iso that you just downloaded is only a day old–the wheezy ISOs have been much more thoroughly tested and I suppose I missed this one aspect. I’ll take a look at it right now to figure out what command can remedy this so that you can continue without any reinstall.

No worries I appreciate all of your effort to make this project as great as it is.

Alright, found the problem. Seems that with the new Jessie foundation, supervisord no longer sets the $HOME variable. Here’s what you’ll do to fix it and I’ll hopefully get this fix onto the new ISO soon before more of this issue arises:

echo 'environment=HOME="/root",USER="root"' >> /etc/supervisor/conf.d/mineos.conf
supervisorctl reread
supervisorctl update

Log back into the webui and it should work now.

UPDATE: this is fixed in the current Jessie ISO now.

Thank you so much for the quick response. Love this project.