[SOLVED] Setting up a Yogscraft Server (fun ensued)

I’m currently trying to set up a YogsCraft server on a MineOS Turnkey box, and I think I may have broken the server in the process.

Since I cannot find a direct download link for the modpack, I created a new unmanaged profile for the YogsCraft server, and have been trying to copy the server files from my desktop into the server box, so far unsuccessfully. The first attempt was the move the files over via USB drive, but it does not seem to have the fstab function as part of the distribution.

I also tried moving the field over using an Ubuntu Live CD, but apparently the var\games\minecraft\profiles\ directories can only be written to by the original root user. I cannot seem t ofind a way to override that via a live CD.

The final attempt was to enter through the :12321 web interface. I attempted to unwrite protect the main drive, but I think in the process I managed to bar root from access to it, and I’m not quite sure how to fix that. I tried a number of times to upload and unzip a zip archive to the YogsCraft profile directory, but while it uploaded the file, it was never able to unzip the contents.

Now when I try to bring up the server, it displays a long list of permission denied errors, and then loops on disabling all the user IDs for 5 minutes, because they sent to many requests.

Is there a way to recover from this without reformatting the server, and how should I have gone about installing the mod server instead?

Based on the symptoms of your computer after what you’ve done, I’d recommend reinstalling Linux; you may have made some drastic changes with latent effects you just won’t want to deal with.

There are a few ways to go about making it work once that is done:

a) upload your file to a dropbox, and use that for the download location


b) use an SFTP client.

Here’s why you had permissions errors and what you can do to successfully move the files.

The short of it is that any given non-root user cannot and should not be able to drop files wherever he feels like it. That’s the essence of restrictive permissions for security and since you know you’re doing something valid and safe, you can:

  1. upload to a directory available to your ‘mc’ user (then use root to move it)
  2. make the destination directory available for non owners to put files in.

Have a read and let me know if you run into any more troubles.

Just to follow up, I have finally gotten the server running.

I used a Ubuntu Live CD to back up my old Vanilla world on the box, and did end up reformatting the server with a fresh install of MineOS Turnkey.

I followed the process for installing a Forge 1.7 server, using the Forge 1.6.4 files, but I do know if it was necessary. I ended up creating a specific profile for the Yogscraft server, that just has the Yogscraft version of Forge 1.6.4- in it. From there I created a new Yogscraft server on my server box, with the name of the serve I wanted to generate.

Then, I created a Yogscraft Server using the ATL Server generator on my windows desktop, and renamed the server directory to the name of the server I was trying to build on the MineOS box. Apparently it just sets up a server, but doesn’t run the world gen until you launch the Forge Jar, so I was able to create the server properties file I was looking for and generate the world on my windows box.

Then I created a zip archive of all of the files in the Yogscraft server I had created on my desktop. From there I used the Turnkey OS admin interface (:12321, log in as root) to copy and extract the zip file into the MineOS server. Since all of those files went up with “root” as the owner, I then went into the Turnkey File Manager, and used the Info button to change the owner and group to mc, and to propagate the change to all files and sub directories.

Then I had to create a new server profile for running the Forge 1.6.4 executable, and set the Yogscraft server to that.

Once all of that was set, I was able to launch the server, log in, and cackle manically about how it had actually worked.

Hopefully other people will find this post useful in figuring out how to set up their own servers.

1 Like