[SOLVED] Server crashing after 5 seconds


#1

Freshly installed MineOS turnkey and tried setting up a minecraft server. I got the minecraft_server.1.10.2.jar in the java settings and downloaded the mojang 1.10.2 profile. I have the Memory allocation set to -Xmx 5120 MB and -Xms 1024mb (1gb to 5gb). After hitting start, it will start up and then automatically go down after 5 seconds. I’m not sure what i’m doing wrong and I cannot find anything in the forums to help. Any suggestions?

Sorry if I put this in the wrong area, new to this forum and I’m just looking for answers.


#2

Are you sure the correct jar was selected and did you accept the EULA? Also are there any logs in the server directory?


Moved to Server-Software_Vanilla


#3

dear pwnuntheface91,

in addition to following JayMontana36’s excellent advices and posting the log so that your issues may diagnosed, please begin to repair your MineOS WebUI by following the instructions at this link:

https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui

then report your progress back here, thanks!

Good Luck!

tNt


#4

JayMontana,

Not sure how to tell if the correct jar was selected, I just have minecraft_server.1.10.2.jar selected in the drop down in the server status screen. I did accept the EULA. I just noticed that log section down at the bottom. Here is what it says after trying to start it up.

[01:46:29] [Server thread/INFO]: Starting minecraft server version 1.10.2
[01:46:29] [Server thread/INFO]: Loading properties
[01:46:29] [Server thread/INFO]: Default game type: CREATIVE
[01:46:29] [Server thread/INFO]: Generating keypair
[01:46:29] [Server thread/INFO]: Starting Minecraft server on 10.0.0.116:25565
[01:46:29] [Server thread/INFO]: Using epoll channel type
[01:46:29] [Server thread/WARN]: **** FAILED TO BIND TO PORT!
[01:46:29] [Server thread/WARN]: The exception was: java.io.IOException: Error during bind(…): Cannot assign requested address
[01:46:29] [Server thread/WARN]: Perhaps a server is already running on that port?
[01:46:29] [Server thread/INFO]: Stopping server
[01:46:29] [Server Shutdown Thread/INFO]: Stopping server


#5

Your logs say what your problem is. It shuts down because it cannot bind your server port to the one you have given.

Have you any other minecrafts servers active?

If this is your only minecraft server, please try to reboot your MineOS machine to free the port.
If this is not the only server, you need to give it it’s own port that are different from the standard. 25566 for example.


#6

iMelsom,

MineOS has it’s own port of 25565 and the minecraft server has its own as well (25566). I’ve made port forwards for them on the firewall. I’m not sure why it’s doing this.


#7

It may also be that the IP address you set isn’t correct, or is no longer correct; that typically happens if/when you use DHCP rather than Static…if it changes then the server will be trying to listen on a port on an IP address that it doesn’t have. If you use the preconfigured ISO make sure the IP in your server.properties matches the one shown on the server screen (and you should probably also set a static IP).


#8

Ah, figured out the problem. I figured that the minecraft server needed to be on a different IP than MineOS. I changed them to be the same and now it’s all working. Thanks everyone for the help!